summaryrefslogtreecommitdiff
path: root/python-sphinxcontrib-asciinema.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 12:11:28 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 12:11:28 +0000
commitcb18374175a788bcbbfa5dad5e8af092b36ce5ad (patch)
tree839d0b3eacb6e98b9827f9def51996ddab600840 /python-sphinxcontrib-asciinema.spec
parent3bccfab7960418779108e2259c3c5f4f13915e56 (diff)
automatic import of python-sphinxcontrib-asciinema
Diffstat (limited to 'python-sphinxcontrib-asciinema.spec')
-rw-r--r--python-sphinxcontrib-asciinema.spec267
1 files changed, 267 insertions, 0 deletions
diff --git a/python-sphinxcontrib-asciinema.spec b/python-sphinxcontrib-asciinema.spec
new file mode 100644
index 0000000..89dcf63
--- /dev/null
+++ b/python-sphinxcontrib-asciinema.spec
@@ -0,0 +1,267 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sphinxcontrib.asciinema
+Version: 0.3.7
+Release: 1
+Summary: Embed asciinema casts in your Sphinx docs
+License: MIT
+URL: https://github.com/divi255/sphinxcontrib.asciinema
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0d/1c/98bdc6d4a7192577e382ec67cde1fdda13b30bb2f999e55c8478bb4bb3f9/sphinxcontrib.asciinema-0.3.7.tar.gz
+BuildArch: noarch
+
+
+%description
+
+# sphinxcontrib-asciinema
+
+Easily embed [asciinema](https://asciinema.org/) videos into Sphinx rst docs.
+
+## Installation
+
+Clone and cd into this repository, then:
+
+```shell
+pip install .
+```
+
+or install from PyPI:
+
+```shell
+pip install sphinxcontrib.asciinema
+```
+
+## Usage
+
+Append extension to sphinx `conf.py`:
+
+```python
+extensions = ['sphinxcontrib.asciinema']
+```
+
+Insert videos into `.rst` docs by embedding them from asciinema.org:
+
+```rst
+.. asciinema:: 261648
+```
+
+or for a local file with a self-hosted web player:
+
+```rst
+.. asciinema:: local_file.cast
+```
+
+It is possible to give options as well:
+
+```rst
+.. asciinema:: local_file.cast
+ :preload: 1
+ :theme: solarized-dark
+```
+
+You can enter all options from the [self-hosted player](https://github.com/asciinema/asciinema-player#asciinema-player-element-attributes)
+and the [embedded asciinema.org player](https://asciinema.org/docs/embedding).
+
+Default options can be set in `conf.py`:
+
+```python
+sphinxcontrib_asciinema_defaults = {
+ 'theme': 'solarized-dark',
+ 'preload': 1,
+ 'font-size': '15px',
+# 'path': 'path/to/castdir'
+}
+```
+
+The "path" option can be specified to set the default cast file directory. If a
+local file path starts with "./", the option is ignored.
+
+
+
+
+%package -n python3-sphinxcontrib.asciinema
+Summary: Embed asciinema casts in your Sphinx docs
+Provides: python-sphinxcontrib.asciinema
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sphinxcontrib.asciinema
+
+# sphinxcontrib-asciinema
+
+Easily embed [asciinema](https://asciinema.org/) videos into Sphinx rst docs.
+
+## Installation
+
+Clone and cd into this repository, then:
+
+```shell
+pip install .
+```
+
+or install from PyPI:
+
+```shell
+pip install sphinxcontrib.asciinema
+```
+
+## Usage
+
+Append extension to sphinx `conf.py`:
+
+```python
+extensions = ['sphinxcontrib.asciinema']
+```
+
+Insert videos into `.rst` docs by embedding them from asciinema.org:
+
+```rst
+.. asciinema:: 261648
+```
+
+or for a local file with a self-hosted web player:
+
+```rst
+.. asciinema:: local_file.cast
+```
+
+It is possible to give options as well:
+
+```rst
+.. asciinema:: local_file.cast
+ :preload: 1
+ :theme: solarized-dark
+```
+
+You can enter all options from the [self-hosted player](https://github.com/asciinema/asciinema-player#asciinema-player-element-attributes)
+and the [embedded asciinema.org player](https://asciinema.org/docs/embedding).
+
+Default options can be set in `conf.py`:
+
+```python
+sphinxcontrib_asciinema_defaults = {
+ 'theme': 'solarized-dark',
+ 'preload': 1,
+ 'font-size': '15px',
+# 'path': 'path/to/castdir'
+}
+```
+
+The "path" option can be specified to set the default cast file directory. If a
+local file path starts with "./", the option is ignored.
+
+
+
+
+%package help
+Summary: Development documents and examples for sphinxcontrib.asciinema
+Provides: python3-sphinxcontrib.asciinema-doc
+%description help
+
+# sphinxcontrib-asciinema
+
+Easily embed [asciinema](https://asciinema.org/) videos into Sphinx rst docs.
+
+## Installation
+
+Clone and cd into this repository, then:
+
+```shell
+pip install .
+```
+
+or install from PyPI:
+
+```shell
+pip install sphinxcontrib.asciinema
+```
+
+## Usage
+
+Append extension to sphinx `conf.py`:
+
+```python
+extensions = ['sphinxcontrib.asciinema']
+```
+
+Insert videos into `.rst` docs by embedding them from asciinema.org:
+
+```rst
+.. asciinema:: 261648
+```
+
+or for a local file with a self-hosted web player:
+
+```rst
+.. asciinema:: local_file.cast
+```
+
+It is possible to give options as well:
+
+```rst
+.. asciinema:: local_file.cast
+ :preload: 1
+ :theme: solarized-dark
+```
+
+You can enter all options from the [self-hosted player](https://github.com/asciinema/asciinema-player#asciinema-player-element-attributes)
+and the [embedded asciinema.org player](https://asciinema.org/docs/embedding).
+
+Default options can be set in `conf.py`:
+
+```python
+sphinxcontrib_asciinema_defaults = {
+ 'theme': 'solarized-dark',
+ 'preload': 1,
+ 'font-size': '15px',
+# 'path': 'path/to/castdir'
+}
+```
+
+The "path" option can be specified to set the default cast file directory. If a
+local file path starts with "./", the option is ignored.
+
+
+
+
+%prep
+%autosetup -n sphinxcontrib.asciinema-0.3.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sphinxcontrib.asciinema -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.7-1
+- Package Spec generated