summaryrefslogtreecommitdiff
path: root/python-splink-graph.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-splink-graph.spec')
-rw-r--r--python-splink-graph.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-splink-graph.spec b/python-splink-graph.spec
new file mode 100644
index 0000000..4f15c4e
--- /dev/null
+++ b/python-splink-graph.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-splink-graph
+Version: 0.8.2
+Release: 1
+Summary: a small set of graph functions to be used from pySpark on top of networkx and graphframes
+License: MIT
+URL: https://github.com/moj-analytical-services/splink_graph
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/5a/487f8d9df419202033dfe576e4815e583a472cd1c1bb38de9c0f609f7061/splink_graph-0.8.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-networkx
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-gensim
+Requires: python3-node2vec
+Requires: python3-graphframes
+
+%description
+`splink_graph` is a graph utility library for use in Apache Spark.
+It computes graph metrics on the outputs of data linking which are useful for:
+- Quality assurance of linkage results and identifying false positive links
+- Computing quality metrics associated with groups (clusters) of linked records
+- Automatically identifying possible false positive links in clusters
+It works with graph data structures such as the ones created from the outputs of data linking - for instance the candidate pair results produced by ![splink](https://github.com/moj-analytical-services/splink)
+
+%package -n python3-splink-graph
+Summary: a small set of graph functions to be used from pySpark on top of networkx and graphframes
+Provides: python-splink-graph
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-splink-graph
+`splink_graph` is a graph utility library for use in Apache Spark.
+It computes graph metrics on the outputs of data linking which are useful for:
+- Quality assurance of linkage results and identifying false positive links
+- Computing quality metrics associated with groups (clusters) of linked records
+- Automatically identifying possible false positive links in clusters
+It works with graph data structures such as the ones created from the outputs of data linking - for instance the candidate pair results produced by ![splink](https://github.com/moj-analytical-services/splink)
+
+%package help
+Summary: Development documents and examples for splink-graph
+Provides: python3-splink-graph-doc
+%description help
+`splink_graph` is a graph utility library for use in Apache Spark.
+It computes graph metrics on the outputs of data linking which are useful for:
+- Quality assurance of linkage results and identifying false positive links
+- Computing quality metrics associated with groups (clusters) of linked records
+- Automatically identifying possible false positive links in clusters
+It works with graph data structures such as the ones created from the outputs of data linking - for instance the candidate pair results produced by ![splink](https://github.com/moj-analytical-services/splink)
+
+%prep
+%autosetup -n splink-graph-0.8.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-splink-graph -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.2-1
+- Package Spec generated