summaryrefslogtreecommitdiff
path: root/python-springlabs-django.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 09:52:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 09:52:42 +0000
commit94ef278084f1aefe6361e2f17e873520884231ae (patch)
tree5dee2f456427f0105c70d91ff62284a19a43df63 /python-springlabs-django.spec
parent17b057c217d2a6b55e8825768068485d5c2b047d (diff)
automatic import of python-springlabs-djangoopeneuler20.03
Diffstat (limited to 'python-springlabs-django.spec')
-rw-r--r--python-springlabs-django.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-springlabs-django.spec b/python-springlabs-django.spec
new file mode 100644
index 0000000..4d30104
--- /dev/null
+++ b/python-springlabs-django.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-springlabs-django
+Version: 0.3.5
+Release: 1
+Summary: Springlabs Projects Django Standard
+License: MIT License
+URL: https://springlabs.ai/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ce/84/777aa4d29a19cce80f5c0d727b27beb4b1a5640c8403a3a3643210103a89/springlabs_django-0.3.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-click
+Requires: python3-requests
+
+%description
+MIT
+[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
+ [Django]: <https://www.djangoproject.com/>
+ [DjangoRestFramework]: <https://www.django-rest-framework.org/>
+ [Graphene-Django]: <https://docs.graphene-python.org/projects/django/en/latest/>
+ [Python]: <https://www.python.org/downloads/release/python-3611/>
+
+%package -n python3-springlabs-django
+Summary: Springlabs Projects Django Standard
+Provides: python-springlabs-django
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-springlabs-django
+MIT
+[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
+ [Django]: <https://www.djangoproject.com/>
+ [DjangoRestFramework]: <https://www.django-rest-framework.org/>
+ [Graphene-Django]: <https://docs.graphene-python.org/projects/django/en/latest/>
+ [Python]: <https://www.python.org/downloads/release/python-3611/>
+
+%package help
+Summary: Development documents and examples for springlabs-django
+Provides: python3-springlabs-django-doc
+%description help
+MIT
+[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
+ [Django]: <https://www.djangoproject.com/>
+ [DjangoRestFramework]: <https://www.django-rest-framework.org/>
+ [Graphene-Django]: <https://docs.graphene-python.org/projects/django/en/latest/>
+ [Python]: <https://www.python.org/downloads/release/python-3611/>
+
+%prep
+%autosetup -n springlabs_django-0.3.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-springlabs-django -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.5-1
+- Package Spec generated