summaryrefslogtreecommitdiff
path: root/python-sqlmatches.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sqlmatches.spec')
-rw-r--r--python-sqlmatches.spec236
1 files changed, 236 insertions, 0 deletions
diff --git a/python-sqlmatches.spec b/python-sqlmatches.spec
new file mode 100644
index 0000000..930caa6
--- /dev/null
+++ b/python-sqlmatches.spec
@@ -0,0 +1,236 @@
+%global _empty_manifest_terminate_build 0
+Name: python-SQLMatches
+Version: 0.3.6
+Release: 1
+Summary: SQLMatches, match & demos recorder.
+License: GPL v3
+URL: https://github.com/WardPearce/SQLMatches
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/99/6e/823e54a7763e342c5e258129a89df75d05ace9be15d9b49dddea731e9b6d/SQLMatches-0.3.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-starlette
+Requires: python3-asyncpg
+Requires: python3-aiomysql
+Requires: python3-aiosqlite
+Requires: python3-databases
+Requires: python3-aiofiles
+Requires: python3-itsdangerous
+Requires: python3-uvicorn
+Requires: python3-sqlalchemy
+Requires: python3-aiohttp
+Requires: python3-webargs
+Requires: python3-webargs-starlette
+Requires: python3-backblaze
+Requires: python3-marshmallow
+Requires: python3-asynctest
+Requires: python3-websockets
+Requires: python3-aiojobs
+Requires: python3-aiocache[redis]
+Requires: python3-msgpack
+Requires: python3-bcrypt
+Requires: python3-socketio
+Requires: python3-validators
+Requires: python3-apispec
+Requires: python3-starlette-apispec
+Requires: python3-cryptography
+Requires: python3-dotenv
+Requires: python3-aiosmtplib
+Requires: python3-Jinja2
+Requires: python3-aioftp
+
+%description
+# Help support SQLMatches development & hosting
+- [Subscribe](https://sqlmatches.com/) to SQLMatches on the 'Owner Panel' under the 'Subscriptions / Billing' tab.
+- [Donate via PayPal](https://www.paypal.com/donate?hosted_button_id=ZGS5RJ9FC94GQ)
+
+
+#### ✨ Help show support by starring this repo! Watch it to get notifications when updated. ✨
+![sellout](https://tinyurl.com/y6br8dx3)
+
+## Setup
+### Hosted version
+- Visit [SQLMatches.com](https://sqlmatches.com) & follow the video.
+- Follow the setup section on the [Plugin](https://github.com/SQLMatches/Plugins#setup) repo.
+
+### Self-hosing
+- Install SQLMatches with ``pip3 install SQLMatches --upgrade``.
+- Create a file like [run.py](/run.py).
+- Set up [uvicorn](https://www.uvicorn.org/deployment/) with Starlette.
+ - I recommend running [Nginx as a reverse proxy](http://www.uvicorn.org/deployment/#running-behind-nginx).
+ - [Production Config](/nginx/production.conf)
+ - [Development Config](/nginx/development.conf)
+ - Use a UDS (UNIX domain socket) for production.
+ - e.g. `uvicorn.run(app, uds="/tmp/uvicorn.sock", log_level="warning")`
+ - SSL with [Certbot](https://certbot.eff.org/).
+ - Setup a SMTP server, I use [Postfix](https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-postfix-as-a-send-only-smtp-server-on-ubuntu-18-04).
+ - Build the [Frontend](https://github.com/SQLMatches/Frontend) or run it in development mode.
+ - If building, make sure to edit line [16](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L16) & [48](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L48) to the location of the built frontend.
+- Run [run.py](/website/run.py) using PM2 or screen.
+
+## Thanks to
+- [WardPearce](https://github.com/WardPearce) - [backblaze](https://github.com/WardPearce/backblaze) - Contributor - Maintainer
+- [encode](https://www.encode.io/) - [databases](https://www.encode.io/databases/) - [uvicorn](http://www.uvicorn.org/) - [starlette](https://www.starlette.io/)
+- [Pallets Projects](https://palletsprojects.com/) - [Jinja2](https://jinja.palletsprojects.com/en/2.11.x/)
+- [Woile](https://github.com/Woile) - [starlette apispec](https://github.com/Woile/starlette-apispec)
+- [Miguel Grinberg](https://github.com/miguelgrinberg) - [socketio](https://github.com/miguelgrinberg/python-socketio)
+- [aio-libs](https://github.com/aio-libs) - [aiocache](https://github.com/aio-libs/aiocache) - [aiohttp](https://github.com/aio-libs/aiohttp) - [aiomysql](https://github.com/aio-libs/aiomysql) - [aiojobs](https://github.com/aio-libs/aiojobs)
+- [cole](https://github.com/cole) - [aiosmtplib](https://github.com/cole/aiosmtplib)
+- [Martin Richard](https://github.com/Martiusweb) - [asynctest](https://github.com/Martiusweb/asynctest/)
+- [marshmallow code](https://github.com/marshmallow-code) - [marshmallow](https://github.com/marshmallow-code/marshmallow) - [webargs](https://github.com/marshmallow-code/webargs)
+- [Steven Loria](https://github.com/sloria) - [webargs starlette](https://github.com/sloria/webargs-starlette)
+- [sqlalchemy](https://www.sqlalchemy.org/)
+- [Tin Tvrtković](https://github.com/Tinche) - [aiofiles](https://github.com/Tinche/aiofiles)
+- [Omnilib](https://github.com/omnilib) - [aiosqlite](https://github.com/omnilib/aiosqlite)
+- [MagicStack](https://github.com/MagicStack) - [asyncpg](https://github.com/MagicStack/asyncpg)
+- To all the developers who helped to make these packages!
+
+
+
+%package -n python3-SQLMatches
+Summary: SQLMatches, match & demos recorder.
+Provides: python-SQLMatches
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-SQLMatches
+# Help support SQLMatches development & hosting
+- [Subscribe](https://sqlmatches.com/) to SQLMatches on the 'Owner Panel' under the 'Subscriptions / Billing' tab.
+- [Donate via PayPal](https://www.paypal.com/donate?hosted_button_id=ZGS5RJ9FC94GQ)
+
+
+#### ✨ Help show support by starring this repo! Watch it to get notifications when updated. ✨
+![sellout](https://tinyurl.com/y6br8dx3)
+
+## Setup
+### Hosted version
+- Visit [SQLMatches.com](https://sqlmatches.com) & follow the video.
+- Follow the setup section on the [Plugin](https://github.com/SQLMatches/Plugins#setup) repo.
+
+### Self-hosing
+- Install SQLMatches with ``pip3 install SQLMatches --upgrade``.
+- Create a file like [run.py](/run.py).
+- Set up [uvicorn](https://www.uvicorn.org/deployment/) with Starlette.
+ - I recommend running [Nginx as a reverse proxy](http://www.uvicorn.org/deployment/#running-behind-nginx).
+ - [Production Config](/nginx/production.conf)
+ - [Development Config](/nginx/development.conf)
+ - Use a UDS (UNIX domain socket) for production.
+ - e.g. `uvicorn.run(app, uds="/tmp/uvicorn.sock", log_level="warning")`
+ - SSL with [Certbot](https://certbot.eff.org/).
+ - Setup a SMTP server, I use [Postfix](https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-postfix-as-a-send-only-smtp-server-on-ubuntu-18-04).
+ - Build the [Frontend](https://github.com/SQLMatches/Frontend) or run it in development mode.
+ - If building, make sure to edit line [16](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L16) & [48](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L48) to the location of the built frontend.
+- Run [run.py](/website/run.py) using PM2 or screen.
+
+## Thanks to
+- [WardPearce](https://github.com/WardPearce) - [backblaze](https://github.com/WardPearce/backblaze) - Contributor - Maintainer
+- [encode](https://www.encode.io/) - [databases](https://www.encode.io/databases/) - [uvicorn](http://www.uvicorn.org/) - [starlette](https://www.starlette.io/)
+- [Pallets Projects](https://palletsprojects.com/) - [Jinja2](https://jinja.palletsprojects.com/en/2.11.x/)
+- [Woile](https://github.com/Woile) - [starlette apispec](https://github.com/Woile/starlette-apispec)
+- [Miguel Grinberg](https://github.com/miguelgrinberg) - [socketio](https://github.com/miguelgrinberg/python-socketio)
+- [aio-libs](https://github.com/aio-libs) - [aiocache](https://github.com/aio-libs/aiocache) - [aiohttp](https://github.com/aio-libs/aiohttp) - [aiomysql](https://github.com/aio-libs/aiomysql) - [aiojobs](https://github.com/aio-libs/aiojobs)
+- [cole](https://github.com/cole) - [aiosmtplib](https://github.com/cole/aiosmtplib)
+- [Martin Richard](https://github.com/Martiusweb) - [asynctest](https://github.com/Martiusweb/asynctest/)
+- [marshmallow code](https://github.com/marshmallow-code) - [marshmallow](https://github.com/marshmallow-code/marshmallow) - [webargs](https://github.com/marshmallow-code/webargs)
+- [Steven Loria](https://github.com/sloria) - [webargs starlette](https://github.com/sloria/webargs-starlette)
+- [sqlalchemy](https://www.sqlalchemy.org/)
+- [Tin Tvrtković](https://github.com/Tinche) - [aiofiles](https://github.com/Tinche/aiofiles)
+- [Omnilib](https://github.com/omnilib) - [aiosqlite](https://github.com/omnilib/aiosqlite)
+- [MagicStack](https://github.com/MagicStack) - [asyncpg](https://github.com/MagicStack/asyncpg)
+- To all the developers who helped to make these packages!
+
+
+
+%package help
+Summary: Development documents and examples for SQLMatches
+Provides: python3-SQLMatches-doc
+%description help
+# Help support SQLMatches development & hosting
+- [Subscribe](https://sqlmatches.com/) to SQLMatches on the 'Owner Panel' under the 'Subscriptions / Billing' tab.
+- [Donate via PayPal](https://www.paypal.com/donate?hosted_button_id=ZGS5RJ9FC94GQ)
+
+
+#### ✨ Help show support by starring this repo! Watch it to get notifications when updated. ✨
+![sellout](https://tinyurl.com/y6br8dx3)
+
+## Setup
+### Hosted version
+- Visit [SQLMatches.com](https://sqlmatches.com) & follow the video.
+- Follow the setup section on the [Plugin](https://github.com/SQLMatches/Plugins#setup) repo.
+
+### Self-hosing
+- Install SQLMatches with ``pip3 install SQLMatches --upgrade``.
+- Create a file like [run.py](/run.py).
+- Set up [uvicorn](https://www.uvicorn.org/deployment/) with Starlette.
+ - I recommend running [Nginx as a reverse proxy](http://www.uvicorn.org/deployment/#running-behind-nginx).
+ - [Production Config](/nginx/production.conf)
+ - [Development Config](/nginx/development.conf)
+ - Use a UDS (UNIX domain socket) for production.
+ - e.g. `uvicorn.run(app, uds="/tmp/uvicorn.sock", log_level="warning")`
+ - SSL with [Certbot](https://certbot.eff.org/).
+ - Setup a SMTP server, I use [Postfix](https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-postfix-as-a-send-only-smtp-server-on-ubuntu-18-04).
+ - Build the [Frontend](https://github.com/SQLMatches/Frontend) or run it in development mode.
+ - If building, make sure to edit line [16](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L16) & [48](https://github.com/SQLMatches/API/blob/master/nginx/production.conf#L48) to the location of the built frontend.
+- Run [run.py](/website/run.py) using PM2 or screen.
+
+## Thanks to
+- [WardPearce](https://github.com/WardPearce) - [backblaze](https://github.com/WardPearce/backblaze) - Contributor - Maintainer
+- [encode](https://www.encode.io/) - [databases](https://www.encode.io/databases/) - [uvicorn](http://www.uvicorn.org/) - [starlette](https://www.starlette.io/)
+- [Pallets Projects](https://palletsprojects.com/) - [Jinja2](https://jinja.palletsprojects.com/en/2.11.x/)
+- [Woile](https://github.com/Woile) - [starlette apispec](https://github.com/Woile/starlette-apispec)
+- [Miguel Grinberg](https://github.com/miguelgrinberg) - [socketio](https://github.com/miguelgrinberg/python-socketio)
+- [aio-libs](https://github.com/aio-libs) - [aiocache](https://github.com/aio-libs/aiocache) - [aiohttp](https://github.com/aio-libs/aiohttp) - [aiomysql](https://github.com/aio-libs/aiomysql) - [aiojobs](https://github.com/aio-libs/aiojobs)
+- [cole](https://github.com/cole) - [aiosmtplib](https://github.com/cole/aiosmtplib)
+- [Martin Richard](https://github.com/Martiusweb) - [asynctest](https://github.com/Martiusweb/asynctest/)
+- [marshmallow code](https://github.com/marshmallow-code) - [marshmallow](https://github.com/marshmallow-code/marshmallow) - [webargs](https://github.com/marshmallow-code/webargs)
+- [Steven Loria](https://github.com/sloria) - [webargs starlette](https://github.com/sloria/webargs-starlette)
+- [sqlalchemy](https://www.sqlalchemy.org/)
+- [Tin Tvrtković](https://github.com/Tinche) - [aiofiles](https://github.com/Tinche/aiofiles)
+- [Omnilib](https://github.com/omnilib) - [aiosqlite](https://github.com/omnilib/aiosqlite)
+- [MagicStack](https://github.com/MagicStack) - [asyncpg](https://github.com/MagicStack/asyncpg)
+- To all the developers who helped to make these packages!
+
+
+
+%prep
+%autosetup -n SQLMatches-0.3.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-SQLMatches -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.6-1
+- Package Spec generated