summaryrefslogtreecommitdiff
path: root/python-starfish-py.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-starfish-py.spec')
-rw-r--r--python-starfish-py.spec125
1 files changed, 125 insertions, 0 deletions
diff --git a/python-starfish-py.spec b/python-starfish-py.spec
new file mode 100644
index 0000000..b5ec20d
--- /dev/null
+++ b/python-starfish-py.spec
@@ -0,0 +1,125 @@
+%global _empty_manifest_terminate_build 0
+Name: python-starfish-py
+Version: 0.17.16
+Release: 1
+Summary: Developer Toolkit for Decentralised Data Ecosystems
+License: Apache Software License 2.0
+URL: https://github.com/datacraft-dsc/starfish-py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/53/75/3c594ea21f3d00888a9088db8538b1c59fb1d01ad11837defe6c613580fe/starfish-py-0.17.16.tar.gz
+BuildArch: noarch
+
+Requires: python3-typing-extensions
+Requires: python3-convex-api-py
+Requires: python3-pycryptodome
+Requires: python3-bumpversion
+Requires: python3-isort
+Requires: python3-mypy
+Requires: python3-flake8
+Requires: python3-pytest
+Requires: python3-pyyaml
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinxcontrib-apidoc
+Requires: python3-sphinxcontrib-plantuml
+Requires: python3-sphinx-automodapi
+Requires: python3-pygments
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinxcontrib-apidoc
+Requires: python3-sphinxcontrib-plantuml
+Requires: python3-sphinx-automodapi
+Requires: python3-pygments
+Requires: python3-flake8
+Requires: python3-pytest
+Requires: python3-isort
+Requires: python3-mypy
+Requires: python3-pyyaml
+
+%description
+## Table of Contents
+ - [About](#about)
+ - [Features](#features)
+ - [Prerequisites](#prerequisites)
+ - [Quickstart](#quickstart)
+ - [Environment variables](#environment-variables)
+ - [Testing](#testing)
+ - [New Version](#new-version)
+ - [Mailing Lists](#mailing-list)
+ - [Maintainers](#maintainers)
+
+%package -n python3-starfish-py
+Summary: Developer Toolkit for Decentralised Data Ecosystems
+Provides: python-starfish-py
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-starfish-py
+## Table of Contents
+ - [About](#about)
+ - [Features](#features)
+ - [Prerequisites](#prerequisites)
+ - [Quickstart](#quickstart)
+ - [Environment variables](#environment-variables)
+ - [Testing](#testing)
+ - [New Version](#new-version)
+ - [Mailing Lists](#mailing-list)
+ - [Maintainers](#maintainers)
+
+%package help
+Summary: Development documents and examples for starfish-py
+Provides: python3-starfish-py-doc
+%description help
+## Table of Contents
+ - [About](#about)
+ - [Features](#features)
+ - [Prerequisites](#prerequisites)
+ - [Quickstart](#quickstart)
+ - [Environment variables](#environment-variables)
+ - [Testing](#testing)
+ - [New Version](#new-version)
+ - [Mailing Lists](#mailing-list)
+ - [Maintainers](#maintainers)
+
+%prep
+%autosetup -n starfish-py-0.17.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-starfish-py -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.17.16-1
+- Package Spec generated