summaryrefslogtreecommitdiff
path: root/python-stdlib-list.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 17:16:02 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 17:16:02 +0000
commita0e3abd39b6ab94cbeddfa1f87228038522ba345 (patch)
tree1ca8f7545044645993678825037b24b40cdfd08c /python-stdlib-list.spec
parent9a087cde97da8db97903308f6f23bce12fda7be2 (diff)
automatic import of python-stdlib-list
Diffstat (limited to 'python-stdlib-list.spec')
-rw-r--r--python-stdlib-list.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-stdlib-list.spec b/python-stdlib-list.spec
new file mode 100644
index 0000000..ccb97f5
--- /dev/null
+++ b/python-stdlib-list.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-stdlib-list
+Version: 0.8.0
+Release: 1
+Summary: A list of Python Standard Libraries (2.6-7, 3.2-9).
+License: MIT
+URL: https://github.com/jackmaney/python-stdlib-list
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/01/237cea071fd305f162ebbe1db18a59b56b0b5fdff19533c9a1beea0bdee7/stdlib-list-0.8.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-functools32
+Requires: python3-sphinx
+
+%description
+This package includes lists of all of the standard libraries for Python 2.6, 2.7, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, and 3.9 along with the code for scraping the official Python docs to get said lists.
+
+%package -n python3-stdlib-list
+Summary: A list of Python Standard Libraries (2.6-7, 3.2-9).
+Provides: python-stdlib-list
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-stdlib-list
+This package includes lists of all of the standard libraries for Python 2.6, 2.7, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, and 3.9 along with the code for scraping the official Python docs to get said lists.
+
+%package help
+Summary: Development documents and examples for stdlib-list
+Provides: python3-stdlib-list-doc
+%description help
+This package includes lists of all of the standard libraries for Python 2.6, 2.7, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, and 3.9 along with the code for scraping the official Python docs to get said lists.
+
+%prep
+%autosetup -n stdlib-list-0.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-stdlib-list -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
+- Package Spec generated