summaryrefslogtreecommitdiff
path: root/python-strainge.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-strainge.spec')
-rw-r--r--python-strainge.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-strainge.spec b/python-strainge.spec
new file mode 100644
index 0000000..6b256dc
--- /dev/null
+++ b/python-strainge.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-strainge
+Version: 1.3.7
+Release: 1
+Summary: Strain Genome Explorer: a tool suite for tracking and characterizing low-abundance strains.
+License: BSD License
+URL: https://pypi.org/project/strainge/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3e/fd/4fe70e14f214b19ef8b70ad8dc60a9238f8e450f41774b938e197aca68b4/strainge-1.3.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-h5py
+Requires: python3-intervaltree
+Requires: python3-matplotlib
+Requires: python3-scikit-bio
+Requires: python3-scikit-learn
+Requires: python3-pysam
+
+%description
+StrainGE is a set of tools to analyse the within-species strain diversity in
+bacterial populations. It consists of two main components: 1) StrainGST: Strain
+Genome Search tool, a tool to find close reference genomes for strains present
+in a sample and 2) StrainGR: Strain Genome Recovery, a tool to perform
+strain-aware variant calling at low coverages.
+[![Documentation Status](https://readthedocs.org/projects/strainge/badge/?version=latest)](https://strainge.readthedocs.io/en/latest/?badge=latest)
+[![Python Package Index](https://img.shields.io/pypi/v/strainge)](https://pypi.org/project/strainge)
+[![DOI](https://zenodo.org/badge/71356920.svg)](https://zenodo.org/badge/latestdoi/71356920)
+
+%package -n python3-strainge
+Summary: Strain Genome Explorer: a tool suite for tracking and characterizing low-abundance strains.
+Provides: python-strainge
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-strainge
+StrainGE is a set of tools to analyse the within-species strain diversity in
+bacterial populations. It consists of two main components: 1) StrainGST: Strain
+Genome Search tool, a tool to find close reference genomes for strains present
+in a sample and 2) StrainGR: Strain Genome Recovery, a tool to perform
+strain-aware variant calling at low coverages.
+[![Documentation Status](https://readthedocs.org/projects/strainge/badge/?version=latest)](https://strainge.readthedocs.io/en/latest/?badge=latest)
+[![Python Package Index](https://img.shields.io/pypi/v/strainge)](https://pypi.org/project/strainge)
+[![DOI](https://zenodo.org/badge/71356920.svg)](https://zenodo.org/badge/latestdoi/71356920)
+
+%package help
+Summary: Development documents and examples for strainge
+Provides: python3-strainge-doc
+%description help
+StrainGE is a set of tools to analyse the within-species strain diversity in
+bacterial populations. It consists of two main components: 1) StrainGST: Strain
+Genome Search tool, a tool to find close reference genomes for strains present
+in a sample and 2) StrainGR: Strain Genome Recovery, a tool to perform
+strain-aware variant calling at low coverages.
+[![Documentation Status](https://readthedocs.org/projects/strainge/badge/?version=latest)](https://strainge.readthedocs.io/en/latest/?badge=latest)
+[![Python Package Index](https://img.shields.io/pypi/v/strainge)](https://pypi.org/project/strainge)
+[![DOI](https://zenodo.org/badge/71356920.svg)](https://zenodo.org/badge/latestdoi/71356920)
+
+%prep
+%autosetup -n strainge-1.3.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-strainge -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.7-1
+- Package Spec generated