summaryrefslogtreecommitdiff
path: root/python-strax.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-strax.spec')
-rw-r--r--python-strax.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-strax.spec b/python-strax.spec
new file mode 100644
index 0000000..36626cc
--- /dev/null
+++ b/python-strax.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-strax
+Version: 1.5.0
+Release: 1
+Summary: Streaming analysis for xenon TPCs
+License: BSD License
+URL: https://github.com/AxFoundation/strax
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/0d/71de760d72a90fbb9edbda5e3286e1850143e773e25f06efcc0156a31d5b/strax-1.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-blosc
+Requires: python3-dill
+Requires: python3-fsspec
+Requires: python3-immutabledict
+Requires: python3-lz4
+Requires: python3-numba
+Requires: python3-numexpr
+Requires: python3-numpy
+Requires: python3-packaging
+Requires: python3-pandas
+Requires: python3-pdmongo
+Requires: python3-psutil
+Requires: python3-pymongo
+Requires: python3-scipy
+Requires: python3-tqdm
+Requires: python3-zarr
+Requires: python3-zstd
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-nbsphinx
+Requires: python3-recommonmark
+Requires: python3-graphviz
+Requires: python3-m2r
+Requires: python3-mistune
+
+%description
+* Fix ipython version by @dachengx in https://github.com/AxFoundation/strax/pull/719
+* Do not change channel when sort_by_time by @dachengx in https://github.com/AxFoundation/strax/pull/718
+* Save hits level information(hits time difference) in peaks by @dachengx in https://github.com/AxFoundation/strax/pull/716
+**Full Changelog**: https://github.com/AxFoundation/strax/compare/v1.4.3...v1.5.0
+
+%package -n python3-strax
+Summary: Streaming analysis for xenon TPCs
+Provides: python-strax
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-strax
+* Fix ipython version by @dachengx in https://github.com/AxFoundation/strax/pull/719
+* Do not change channel when sort_by_time by @dachengx in https://github.com/AxFoundation/strax/pull/718
+* Save hits level information(hits time difference) in peaks by @dachengx in https://github.com/AxFoundation/strax/pull/716
+**Full Changelog**: https://github.com/AxFoundation/strax/compare/v1.4.3...v1.5.0
+
+%package help
+Summary: Development documents and examples for strax
+Provides: python3-strax-doc
+%description help
+* Fix ipython version by @dachengx in https://github.com/AxFoundation/strax/pull/719
+* Do not change channel when sort_by_time by @dachengx in https://github.com/AxFoundation/strax/pull/718
+* Save hits level information(hits time difference) in peaks by @dachengx in https://github.com/AxFoundation/strax/pull/716
+**Full Changelog**: https://github.com/AxFoundation/strax/compare/v1.4.3...v1.5.0
+
+%prep
+%autosetup -n strax-1.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-strax -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.0-1
+- Package Spec generated