summaryrefslogtreecommitdiff
path: root/python-streamlink.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 17:19:04 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 17:19:04 +0000
commita17c0ce653b9e7df22d82dfb824894b66322d371 (patch)
tree48d7bfd712a5eadfa01138ae8400f81487018898 /python-streamlink.spec
parent84ead712748317ad9634f514428d377efe8f3ba1 (diff)
automatic import of python-streamlink
Diffstat (limited to 'python-streamlink.spec')
-rw-r--r--python-streamlink.spec336
1 files changed, 336 insertions, 0 deletions
diff --git a/python-streamlink.spec b/python-streamlink.spec
new file mode 100644
index 0000000..7ca9838
--- /dev/null
+++ b/python-streamlink.spec
@@ -0,0 +1,336 @@
+%global _empty_manifest_terminate_build 0
+Name: python-streamlink
+Version: 5.3.1
+Release: 1
+Summary: Streamlink is a command-line utility that extracts streams from various services and pipes them into a video player of choice.
+License: Simplified BSD
+URL: https://github.com/streamlink/streamlink
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/69/e2/a30254048c9be8667ff647d6c79f1aae3fc20fc9cfcfbced15b1256a6d55/streamlink-5.3.1.tar.gz
+
+Requires: python3-certifi
+Requires: python3-isodate
+Requires: python3-lxml
+Requires: python3-pycountry
+Requires: python3-pycryptodome
+Requires: python3-PySocks
+Requires: python3-requests
+Requires: python3-urllib3
+Requires: python3-websocket-client
+Requires: python3-importlib-metadata
+
+%description
+<h1 align="center"><a href="https://streamlink.github.io/">Streamlink<br><img height="150" alt="Streamlink" src="https://raw.githubusercontent.com/streamlink/streamlink/master/icon.svg"></a></h1>
+
+<p align="center">
+ <a href="https://streamlink.github.io/install.html"><img alt="Supported Python versions" src="https://img.shields.io/pypi/pyversions/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://streamlink.github.io/changelog.html"><img alt="Latest release" src="https://img.shields.io/github/release/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink"><img alt="License" src="https://img.shields.io/github/license/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/issues"><img alt="Open issues" src="https://img.shields.io/github/issues/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/actions?query=event%3Apush"><img alt="Build status" src="https://img.shields.io/github/actions/workflow/status/streamlink/streamlink/main.yml?branch=master&event=push&style=flat-square&maxAge=86400"></a>
+ <a href="https://codecov.io/github/streamlink/streamlink?branch=master"><img alt="Overall code coverage" src="https://img.shields.io/codecov/c/github/streamlink/streamlink.svg?branch=master&style=flat-square&maxAge=86400"></a>
+</p>
+
+<p align="center">
+ A Python library and command-line interface which pipes streams from various services into a video player.<br>
+ Avoid resource-heavy and unoptimized websites, and still enjoy streamed content.
+</p>
+
+<p align="center">
+ Streamlink was forked in 2016 from the abandoned <em>Livestreamer</em> project.
+</p>
+
+
+# 📦 Installation
+
+Please take a look at the documentation for different ways of installing Streamlink:
+
+- [Windows][streamlink-installation-windows]
+- [macOS][streamlink-installation-macos]
+- [Linux and BSD][streamlink-installation-linux-and-bsd]
+- [PyPI package and source code][streamlink-installation-pypi-source]
+
+
+# 👍 Features
+
+Streamlink is built on top of a plugin system which allows support for new services to be added easily.
+
+Most of the popular streaming services are supported, such as:
+
+- [Twitch](https://www.twitch.tv)
+- [YouTube](https://www.youtube.com)
+- [Livestream](https://livestream.com)
+- [Dailymotion](https://www.dailymotion.com)
+
+... and many more. A list of all plugins currently included can be found on the [plugins page][streamlink-plugins].
+
+
+# 💡 Quickstart
+
+After installing, simply run:
+
+```sh
+streamlink "STREAMURL" best
+```
+
+The default behavior of Streamlink is to play back streams in the [VLC player][player-vlc], but a lot of other options and output methods are available, such as writing the stream to the filesystem, reading stream metadata, etc.
+
+For more in-depth usage, please refer to the [CLI documentation][streamlink-documentation-cli].
+
+An [API guide][streamlink-documentation-apiguide] and [API reference][streamlink-documentation-apiref] is available for Python implementors of Streamlink.
+
+
+# 🙏 Contributing
+
+All contributions are welcome.
+Feel free to open a new thread on the issue tracker or submit a new pull request.
+Please read [CONTRIBUTING.md][contributing] first. Thanks!
+
+
+# ❤️ Support
+
+If you think that Streamlink is useful and if you want to keep the project alive, then please consider supporting its maintainers by sending a small and optionally recurring tip via the [available options][support].
+Your support is very much appreciated, thank you!
+
+
+ [streamlink-installation-windows]: https://streamlink.github.io/install.html#windows
+ [streamlink-installation-macos]: https://streamlink.github.io/install.html#macos
+ [streamlink-installation-linux-and-bsd]: https://streamlink.github.io/install.html#linux-and-bsd
+ [streamlink-installation-pypi-source]: https://streamlink.github.io/install.html#pypi-package-and-source-code
+ [streamlink-documentation-cli]: https://streamlink.github.io/cli.html
+ [streamlink-documentation-apiguide]: https://streamlink.github.io/api_guide.html
+ [streamlink-documentation-apiref]: https://streamlink.github.io/api.html
+ [streamlink-plugins]: https://streamlink.github.io/plugins.html
+ [player-vlc]: https://www.videolan.org/vlc/
+ [contributing]: https://github.com/streamlink/streamlink/blob/master/CONTRIBUTING.md
+ [support]: https://streamlink.github.io/latest/donate.html
+
+
+%package -n python3-streamlink
+Summary: Streamlink is a command-line utility that extracts streams from various services and pipes them into a video player of choice.
+Provides: python-streamlink
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-streamlink
+<h1 align="center"><a href="https://streamlink.github.io/">Streamlink<br><img height="150" alt="Streamlink" src="https://raw.githubusercontent.com/streamlink/streamlink/master/icon.svg"></a></h1>
+
+<p align="center">
+ <a href="https://streamlink.github.io/install.html"><img alt="Supported Python versions" src="https://img.shields.io/pypi/pyversions/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://streamlink.github.io/changelog.html"><img alt="Latest release" src="https://img.shields.io/github/release/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink"><img alt="License" src="https://img.shields.io/github/license/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/issues"><img alt="Open issues" src="https://img.shields.io/github/issues/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/actions?query=event%3Apush"><img alt="Build status" src="https://img.shields.io/github/actions/workflow/status/streamlink/streamlink/main.yml?branch=master&event=push&style=flat-square&maxAge=86400"></a>
+ <a href="https://codecov.io/github/streamlink/streamlink?branch=master"><img alt="Overall code coverage" src="https://img.shields.io/codecov/c/github/streamlink/streamlink.svg?branch=master&style=flat-square&maxAge=86400"></a>
+</p>
+
+<p align="center">
+ A Python library and command-line interface which pipes streams from various services into a video player.<br>
+ Avoid resource-heavy and unoptimized websites, and still enjoy streamed content.
+</p>
+
+<p align="center">
+ Streamlink was forked in 2016 from the abandoned <em>Livestreamer</em> project.
+</p>
+
+
+# 📦 Installation
+
+Please take a look at the documentation for different ways of installing Streamlink:
+
+- [Windows][streamlink-installation-windows]
+- [macOS][streamlink-installation-macos]
+- [Linux and BSD][streamlink-installation-linux-and-bsd]
+- [PyPI package and source code][streamlink-installation-pypi-source]
+
+
+# 👍 Features
+
+Streamlink is built on top of a plugin system which allows support for new services to be added easily.
+
+Most of the popular streaming services are supported, such as:
+
+- [Twitch](https://www.twitch.tv)
+- [YouTube](https://www.youtube.com)
+- [Livestream](https://livestream.com)
+- [Dailymotion](https://www.dailymotion.com)
+
+... and many more. A list of all plugins currently included can be found on the [plugins page][streamlink-plugins].
+
+
+# 💡 Quickstart
+
+After installing, simply run:
+
+```sh
+streamlink "STREAMURL" best
+```
+
+The default behavior of Streamlink is to play back streams in the [VLC player][player-vlc], but a lot of other options and output methods are available, such as writing the stream to the filesystem, reading stream metadata, etc.
+
+For more in-depth usage, please refer to the [CLI documentation][streamlink-documentation-cli].
+
+An [API guide][streamlink-documentation-apiguide] and [API reference][streamlink-documentation-apiref] is available for Python implementors of Streamlink.
+
+
+# 🙏 Contributing
+
+All contributions are welcome.
+Feel free to open a new thread on the issue tracker or submit a new pull request.
+Please read [CONTRIBUTING.md][contributing] first. Thanks!
+
+
+# ❤️ Support
+
+If you think that Streamlink is useful and if you want to keep the project alive, then please consider supporting its maintainers by sending a small and optionally recurring tip via the [available options][support].
+Your support is very much appreciated, thank you!
+
+
+ [streamlink-installation-windows]: https://streamlink.github.io/install.html#windows
+ [streamlink-installation-macos]: https://streamlink.github.io/install.html#macos
+ [streamlink-installation-linux-and-bsd]: https://streamlink.github.io/install.html#linux-and-bsd
+ [streamlink-installation-pypi-source]: https://streamlink.github.io/install.html#pypi-package-and-source-code
+ [streamlink-documentation-cli]: https://streamlink.github.io/cli.html
+ [streamlink-documentation-apiguide]: https://streamlink.github.io/api_guide.html
+ [streamlink-documentation-apiref]: https://streamlink.github.io/api.html
+ [streamlink-plugins]: https://streamlink.github.io/plugins.html
+ [player-vlc]: https://www.videolan.org/vlc/
+ [contributing]: https://github.com/streamlink/streamlink/blob/master/CONTRIBUTING.md
+ [support]: https://streamlink.github.io/latest/donate.html
+
+
+%package help
+Summary: Development documents and examples for streamlink
+Provides: python3-streamlink-doc
+%description help
+<h1 align="center"><a href="https://streamlink.github.io/">Streamlink<br><img height="150" alt="Streamlink" src="https://raw.githubusercontent.com/streamlink/streamlink/master/icon.svg"></a></h1>
+
+<p align="center">
+ <a href="https://streamlink.github.io/install.html"><img alt="Supported Python versions" src="https://img.shields.io/pypi/pyversions/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://streamlink.github.io/changelog.html"><img alt="Latest release" src="https://img.shields.io/github/release/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink"><img alt="License" src="https://img.shields.io/github/license/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/issues"><img alt="Open issues" src="https://img.shields.io/github/issues/streamlink/streamlink.svg?style=flat-square&maxAge=86400"></a>
+ <a href="https://github.com/streamlink/streamlink/actions?query=event%3Apush"><img alt="Build status" src="https://img.shields.io/github/actions/workflow/status/streamlink/streamlink/main.yml?branch=master&event=push&style=flat-square&maxAge=86400"></a>
+ <a href="https://codecov.io/github/streamlink/streamlink?branch=master"><img alt="Overall code coverage" src="https://img.shields.io/codecov/c/github/streamlink/streamlink.svg?branch=master&style=flat-square&maxAge=86400"></a>
+</p>
+
+<p align="center">
+ A Python library and command-line interface which pipes streams from various services into a video player.<br>
+ Avoid resource-heavy and unoptimized websites, and still enjoy streamed content.
+</p>
+
+<p align="center">
+ Streamlink was forked in 2016 from the abandoned <em>Livestreamer</em> project.
+</p>
+
+
+# 📦 Installation
+
+Please take a look at the documentation for different ways of installing Streamlink:
+
+- [Windows][streamlink-installation-windows]
+- [macOS][streamlink-installation-macos]
+- [Linux and BSD][streamlink-installation-linux-and-bsd]
+- [PyPI package and source code][streamlink-installation-pypi-source]
+
+
+# 👍 Features
+
+Streamlink is built on top of a plugin system which allows support for new services to be added easily.
+
+Most of the popular streaming services are supported, such as:
+
+- [Twitch](https://www.twitch.tv)
+- [YouTube](https://www.youtube.com)
+- [Livestream](https://livestream.com)
+- [Dailymotion](https://www.dailymotion.com)
+
+... and many more. A list of all plugins currently included can be found on the [plugins page][streamlink-plugins].
+
+
+# 💡 Quickstart
+
+After installing, simply run:
+
+```sh
+streamlink "STREAMURL" best
+```
+
+The default behavior of Streamlink is to play back streams in the [VLC player][player-vlc], but a lot of other options and output methods are available, such as writing the stream to the filesystem, reading stream metadata, etc.
+
+For more in-depth usage, please refer to the [CLI documentation][streamlink-documentation-cli].
+
+An [API guide][streamlink-documentation-apiguide] and [API reference][streamlink-documentation-apiref] is available for Python implementors of Streamlink.
+
+
+# 🙏 Contributing
+
+All contributions are welcome.
+Feel free to open a new thread on the issue tracker or submit a new pull request.
+Please read [CONTRIBUTING.md][contributing] first. Thanks!
+
+
+# ❤️ Support
+
+If you think that Streamlink is useful and if you want to keep the project alive, then please consider supporting its maintainers by sending a small and optionally recurring tip via the [available options][support].
+Your support is very much appreciated, thank you!
+
+
+ [streamlink-installation-windows]: https://streamlink.github.io/install.html#windows
+ [streamlink-installation-macos]: https://streamlink.github.io/install.html#macos
+ [streamlink-installation-linux-and-bsd]: https://streamlink.github.io/install.html#linux-and-bsd
+ [streamlink-installation-pypi-source]: https://streamlink.github.io/install.html#pypi-package-and-source-code
+ [streamlink-documentation-cli]: https://streamlink.github.io/cli.html
+ [streamlink-documentation-apiguide]: https://streamlink.github.io/api_guide.html
+ [streamlink-documentation-apiref]: https://streamlink.github.io/api.html
+ [streamlink-plugins]: https://streamlink.github.io/plugins.html
+ [player-vlc]: https://www.videolan.org/vlc/
+ [contributing]: https://github.com/streamlink/streamlink/blob/master/CONTRIBUTING.md
+ [support]: https://streamlink.github.io/latest/donate.html
+
+
+%prep
+%autosetup -n streamlink-5.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-streamlink -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 5.3.1-1
+- Package Spec generated