summaryrefslogtreecommitdiff
path: root/python-sublime-music.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sublime-music.spec')
-rw-r--r--python-sublime-music.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-sublime-music.spec b/python-sublime-music.spec
new file mode 100644
index 0000000..3e0b343
--- /dev/null
+++ b/python-sublime-music.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sublime-music
+Version: 0.11.16
+Release: 1
+Summary: A native GTK *sonic client.
+License: GPL-3.0-or-later
+URL: https://sublimemusic.app
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f3/08/7f47d9c65770fef9c6e42c2439fe8f09cb6b4f48eb4c9464c88173b28acc/sublime_music-0.11.16.tar.gz
+BuildArch: noarch
+
+Requires: python3-bleach
+Requires: python3-bottle
+Requires: python3-dataclasses-json
+Requires: python3-deepdiff
+Requires: python3-fuzzywuzzy
+Requires: python3-keyring
+Requires: python3-peewee
+Requires: python3-pychromecast
+Requires: python3-PyGObject
+Requires: python3-dateutil
+Requires: python3-Levenshtein
+Requires: python3-mpv
+Requires: python3-requests
+Requires: python3-semver
+
+%description
+ The Albums tab of Sublime Music with the Play Queue opened. `More
+ Screenshots <https://sublime-music.gitlab.io/sublime-music/screenshots.html>`_
+
+%package -n python3-sublime-music
+Summary: A native GTK *sonic client.
+Provides: python-sublime-music
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sublime-music
+ The Albums tab of Sublime Music with the Play Queue opened. `More
+ Screenshots <https://sublime-music.gitlab.io/sublime-music/screenshots.html>`_
+
+%package help
+Summary: Development documents and examples for sublime-music
+Provides: python3-sublime-music-doc
+%description help
+ The Albums tab of Sublime Music with the Play Queue opened. `More
+ Screenshots <https://sublime-music.gitlab.io/sublime-music/screenshots.html>`_
+
+%prep
+%autosetup -n sublime-music-0.11.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sublime-music -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.16-1
+- Package Spec generated