summaryrefslogtreecommitdiff
path: root/python-subprocess32-ext.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-subprocess32-ext.spec')
-rw-r--r--python-subprocess32-ext.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-subprocess32-ext.spec b/python-subprocess32-ext.spec
new file mode 100644
index 0000000..a235454
--- /dev/null
+++ b/python-subprocess32-ext.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-subprocess32-ext
+Version: 3.2.8.2
+Release: 1
+Summary: A backport of the subprocess module from Python 3.2/3.3 for use on 2.x.
+License: PSF license
+URL: https://github.com/google/python-subprocess32
+Source0: https://mirrors.aliyun.com/pypi/web/packages/48/68/691c83b6b5632020dbb98321643692835eee7d396583a85e1e634b06a4c9/subprocess32-ext-3.2.8.2.tar.gz
+BuildArch: noarch
+
+
+%description
+This is a backport of the subprocess standard library module from
+Python 3.2 & 3.3 for use on Python 2.
+
+It includes bugfixes and some new features. On POSIX systems it is
+guaranteed to be reliable when used in threaded applications.
+It includes timeout support from Python 3.3 but otherwise matches
+3.2's API.
+
+It has not been tested by the author on Windows.
+
+On Python 3, it merely redirects the subprocess32 name to subprocess.
+
+%package -n python3-subprocess32-ext
+Summary: A backport of the subprocess module from Python 3.2/3.3 for use on 2.x.
+Provides: python-subprocess32-ext
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-subprocess32-ext
+This is a backport of the subprocess standard library module from
+Python 3.2 & 3.3 for use on Python 2.
+
+It includes bugfixes and some new features. On POSIX systems it is
+guaranteed to be reliable when used in threaded applications.
+It includes timeout support from Python 3.3 but otherwise matches
+3.2's API.
+
+It has not been tested by the author on Windows.
+
+On Python 3, it merely redirects the subprocess32 name to subprocess.
+
+%package help
+Summary: Development documents and examples for subprocess32-ext
+Provides: python3-subprocess32-ext-doc
+%description help
+This is a backport of the subprocess standard library module from
+Python 3.2 & 3.3 for use on Python 2.
+
+It includes bugfixes and some new features. On POSIX systems it is
+guaranteed to be reliable when used in threaded applications.
+It includes timeout support from Python 3.3 but otherwise matches
+3.2's API.
+
+It has not been tested by the author on Windows.
+
+On Python 3, it merely redirects the subprocess32 name to subprocess.
+
+%prep
+%autosetup -n subprocess32-ext-3.2.8.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-subprocess32-ext -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.8.2-1
+- Package Spec generated