summaryrefslogtreecommitdiff
path: root/python-sudachidict-full.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sudachidict-full.spec')
-rw-r--r--python-sudachidict-full.spec222
1 files changed, 222 insertions, 0 deletions
diff --git a/python-sudachidict-full.spec b/python-sudachidict-full.spec
new file mode 100644
index 0000000..266bfeb
--- /dev/null
+++ b/python-sudachidict-full.spec
@@ -0,0 +1,222 @@
+%global _empty_manifest_terminate_build 0
+Name: python-SudachiDict-full
+Version: 20230110
+Release: 1
+Summary: Sudachi Dictionary for SudachiPy - Full Edition
+License: Apache-2.0
+URL: https://github.com/WorksApplications/SudachiDict
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/60/c1/8cf66b45dbbd8cd1746fe9a094dc8f5f23fa401f7ce2cd2e2619d923d56b/SudachiDict-full-20230110.tar.gz
+BuildArch: noarch
+
+
+%description
+# Sudachi Dictionary for SudachiPy
+
+- [WorksApplications/SudachiDict](https://github.com/WorksApplications/SudachiDict)
+- [WorksApplications/SudachiPy](https://github.com/WorksApplications/SudachiPy)
+
+Managing the dictionary resources as Python packages.
+
+- [SudachiDict-small · PyPI](https://pypi.org/project/SudachiDict-small/)
+- [SudachiDict-core · PyPI](https://pypi.org/project/SudachiDict-core/)
+- [SudachiDict-full · PyPI](https://pypi.org/project/SudachiDict-full/)
+
+The dictionary files are not included in the packages; It will be downloaded upon installation (the procedure in `setup.py`).
+
+The version (e.g., `20200330`) and the edition (`small`, `core`, or `full`) is specified in `INFO.json`.
+
+## Commands to download and set the dictionaries
+
+In SudachiPy v0.5.2 and later, you can specify a dictionary directly from a command line or program.
+
+**WARNING: `sudachipy link` is no longer available in SudachiPy v0.5.2 and later.**
+
+Please see the following links for more details on the dictionary option.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy#dictionary-edition](https://github.com/WorksApplications/SudachiPy#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+### Install
+
+```bash
+pip install sudachidict_core
+```
+
+```bash
+pip install sudachidict_small
+```
+
+```bash
+pip install sudachidict_full
+```
+
+### Dictionary option in SudachiPy before v0.5.2
+
+In case you are using SudachiPy before v0.5.2, please visit the old SudachiPy documentation.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition](https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+
+%package -n python3-SudachiDict-full
+Summary: Sudachi Dictionary for SudachiPy - Full Edition
+Provides: python-SudachiDict-full
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-SudachiDict-full
+# Sudachi Dictionary for SudachiPy
+
+- [WorksApplications/SudachiDict](https://github.com/WorksApplications/SudachiDict)
+- [WorksApplications/SudachiPy](https://github.com/WorksApplications/SudachiPy)
+
+Managing the dictionary resources as Python packages.
+
+- [SudachiDict-small · PyPI](https://pypi.org/project/SudachiDict-small/)
+- [SudachiDict-core · PyPI](https://pypi.org/project/SudachiDict-core/)
+- [SudachiDict-full · PyPI](https://pypi.org/project/SudachiDict-full/)
+
+The dictionary files are not included in the packages; It will be downloaded upon installation (the procedure in `setup.py`).
+
+The version (e.g., `20200330`) and the edition (`small`, `core`, or `full`) is specified in `INFO.json`.
+
+## Commands to download and set the dictionaries
+
+In SudachiPy v0.5.2 and later, you can specify a dictionary directly from a command line or program.
+
+**WARNING: `sudachipy link` is no longer available in SudachiPy v0.5.2 and later.**
+
+Please see the following links for more details on the dictionary option.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy#dictionary-edition](https://github.com/WorksApplications/SudachiPy#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+### Install
+
+```bash
+pip install sudachidict_core
+```
+
+```bash
+pip install sudachidict_small
+```
+
+```bash
+pip install sudachidict_full
+```
+
+### Dictionary option in SudachiPy before v0.5.2
+
+In case you are using SudachiPy before v0.5.2, please visit the old SudachiPy documentation.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition](https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+
+%package help
+Summary: Development documents and examples for SudachiDict-full
+Provides: python3-SudachiDict-full-doc
+%description help
+# Sudachi Dictionary for SudachiPy
+
+- [WorksApplications/SudachiDict](https://github.com/WorksApplications/SudachiDict)
+- [WorksApplications/SudachiPy](https://github.com/WorksApplications/SudachiPy)
+
+Managing the dictionary resources as Python packages.
+
+- [SudachiDict-small · PyPI](https://pypi.org/project/SudachiDict-small/)
+- [SudachiDict-core · PyPI](https://pypi.org/project/SudachiDict-core/)
+- [SudachiDict-full · PyPI](https://pypi.org/project/SudachiDict-full/)
+
+The dictionary files are not included in the packages; It will be downloaded upon installation (the procedure in `setup.py`).
+
+The version (e.g., `20200330`) and the edition (`small`, `core`, or `full`) is specified in `INFO.json`.
+
+## Commands to download and set the dictionaries
+
+In SudachiPy v0.5.2 and later, you can specify a dictionary directly from a command line or program.
+
+**WARNING: `sudachipy link` is no longer available in SudachiPy v0.5.2 and later.**
+
+Please see the following links for more details on the dictionary option.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy#dictionary-edition](https://github.com/WorksApplications/SudachiPy#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/develop/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+### Install
+
+```bash
+pip install sudachidict_core
+```
+
+```bash
+pip install sudachidict_small
+```
+
+```bash
+pip install sudachidict_full
+```
+
+### Dictionary option in SudachiPy before v0.5.2
+
+In case you are using SudachiPy before v0.5.2, please visit the old SudachiPy documentation.
+
+- english
+ - [https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition](https://github.com/WorksApplications/SudachiPy/tree/v0.5.1#dictionary-edition)
+- japanese
+ - [https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%辞書の種類](https://github.com/WorksApplications/SudachiPy/blob/v0.5.1/docs/tutorial.md#%E8%BE%9E%E6%9B%B8%E3%81%AE%E7%A8%AE%E9%A1%9E)
+
+
+%prep
+%autosetup -n SudachiDict-full-20230110
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-SudachiDict-full -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 20230110-1
+- Package Spec generated