summaryrefslogtreecommitdiff
path: root/python-telepath.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 23:11:58 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 23:11:58 +0000
commitbf9063493d67be83884c31e266bacb47b9d14cb9 (patch)
tree196c9cb9f4765b5ed5b1dd18eb2f9392bed1569b /python-telepath.spec
parentcce876f4e2c9225864feb98456dd27be0839fbd6 (diff)
automatic import of python-telepath
Diffstat (limited to 'python-telepath.spec')
-rw-r--r--python-telepath.spec107
1 files changed, 107 insertions, 0 deletions
diff --git a/python-telepath.spec b/python-telepath.spec
new file mode 100644
index 0000000..fc2958a
--- /dev/null
+++ b/python-telepath.spec
@@ -0,0 +1,107 @@
+%global _empty_manifest_terminate_build 0
+Name: python-telepath
+Version: 0.3
+Release: 1
+Summary: A library for exchanging data between Python and JavaScript
+License: BSD
+URL: https://github.com/wagtail/telepath
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b5/cd/470e2a9a4687440b9842e1928910a7e2d328b0ec4c9f6350d455dba9b235/telepath-0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-mkdocs
+Requires: python3-mkdocs-material
+
+%description
+# telepath
+
+*telepath* is a Django library for exchanging data between Python and JavaScript, allowing you to build apps with rich client-side interfaces while keeping the business logic in server-side code.
+
+## What does it do?
+
+It provides a mechanism for packing structured data, including Python objects, into a JSON-serializable format. This mechanism can be extended to support any Python class, by registering the class with a corresponding JavaScript implementation. The packed data can then be included in an HTTP response, and unpacked in JavaScript to obtain an equivalent data structure to the original. Think of it as [`pickle`](https://docs.python.org/3/library/pickle.html), but with the unpickling happening in the browser.
+
+Full documentation: https://wagtail.github.io/telepath/
+
+
+
+
+%package -n python3-telepath
+Summary: A library for exchanging data between Python and JavaScript
+Provides: python-telepath
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-telepath
+# telepath
+
+*telepath* is a Django library for exchanging data between Python and JavaScript, allowing you to build apps with rich client-side interfaces while keeping the business logic in server-side code.
+
+## What does it do?
+
+It provides a mechanism for packing structured data, including Python objects, into a JSON-serializable format. This mechanism can be extended to support any Python class, by registering the class with a corresponding JavaScript implementation. The packed data can then be included in an HTTP response, and unpacked in JavaScript to obtain an equivalent data structure to the original. Think of it as [`pickle`](https://docs.python.org/3/library/pickle.html), but with the unpickling happening in the browser.
+
+Full documentation: https://wagtail.github.io/telepath/
+
+
+
+
+%package help
+Summary: Development documents and examples for telepath
+Provides: python3-telepath-doc
+%description help
+# telepath
+
+*telepath* is a Django library for exchanging data between Python and JavaScript, allowing you to build apps with rich client-side interfaces while keeping the business logic in server-side code.
+
+## What does it do?
+
+It provides a mechanism for packing structured data, including Python objects, into a JSON-serializable format. This mechanism can be extended to support any Python class, by registering the class with a corresponding JavaScript implementation. The packed data can then be included in an HTTP response, and unpacked in JavaScript to obtain an equivalent data structure to the original. Think of it as [`pickle`](https://docs.python.org/3/library/pickle.html), but with the unpickling happening in the browser.
+
+Full documentation: https://wagtail.github.io/telepath/
+
+
+
+
+%prep
+%autosetup -n telepath-0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-telepath -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3-1
+- Package Spec generated