summaryrefslogtreecommitdiff
path: root/python-theblockchainapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-theblockchainapi.spec')
-rw-r--r--python-theblockchainapi.spec160
1 files changed, 160 insertions, 0 deletions
diff --git a/python-theblockchainapi.spec b/python-theblockchainapi.spec
new file mode 100644
index 0000000..9d7f3eb
--- /dev/null
+++ b/python-theblockchainapi.spec
@@ -0,0 +1,160 @@
+%global _empty_manifest_terminate_build 0
+Name: python-theblockchainapi
+Version: 0.0.604
+Release: 1
+Summary: Blockchain made easy. Find out more at docs.blockchainapi.com.
+License: MIT License
+URL: https://github.com/BL0CK-X/the-blockchain-api
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a0/5c/4d209633e4d16b6a4ed7f116ee2085df2e262052620f3bf9f892dbacbb75/theblockchainapi-0.0.604.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+# The Blockchain API
+
+Submit issues and feature requests for our API on our <a href="https://github.com/BL0CK-X/the-blockchain-api">main GitHub repository</a>.
+
+See <a href="https://docs.theblockchainapi.com">the docs</a> for more info.
+
+## Python Quick Start
+
+`pip install theblockchainapi`
+
+Get an API key pair at <a href="https://dashboard.theblockchainapi.com">dashboard.theblockchainapi.com</a>.
+
+`from theblockchainapi import TheBlockchainAPIResource`
+
+`result = TheBlockchainAPIResource("APIKeyID", "APISecretKey").generate_secret_key()`
+
+`print(result)`
+
+There are many examples using this package <a href="https://github.com/BL0CK-X/the-blockchain-api/tree/main/examples">here</a>.
+
+## Python Documentation
+
+To get a list of available functions, run `help(TheBlockchainAPIResource)` after importing `TheBlockchainAPIResource` as shown above.
+
+## Documentation
+
+For full API documentation, check out <a href="https://docs.theblockchainapi.com">the docs</a>.
+
+
+
+
+%package -n python3-theblockchainapi
+Summary: Blockchain made easy. Find out more at docs.blockchainapi.com.
+Provides: python-theblockchainapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-theblockchainapi
+# The Blockchain API
+
+Submit issues and feature requests for our API on our <a href="https://github.com/BL0CK-X/the-blockchain-api">main GitHub repository</a>.
+
+See <a href="https://docs.theblockchainapi.com">the docs</a> for more info.
+
+## Python Quick Start
+
+`pip install theblockchainapi`
+
+Get an API key pair at <a href="https://dashboard.theblockchainapi.com">dashboard.theblockchainapi.com</a>.
+
+`from theblockchainapi import TheBlockchainAPIResource`
+
+`result = TheBlockchainAPIResource("APIKeyID", "APISecretKey").generate_secret_key()`
+
+`print(result)`
+
+There are many examples using this package <a href="https://github.com/BL0CK-X/the-blockchain-api/tree/main/examples">here</a>.
+
+## Python Documentation
+
+To get a list of available functions, run `help(TheBlockchainAPIResource)` after importing `TheBlockchainAPIResource` as shown above.
+
+## Documentation
+
+For full API documentation, check out <a href="https://docs.theblockchainapi.com">the docs</a>.
+
+
+
+
+%package help
+Summary: Development documents and examples for theblockchainapi
+Provides: python3-theblockchainapi-doc
+%description help
+# The Blockchain API
+
+Submit issues and feature requests for our API on our <a href="https://github.com/BL0CK-X/the-blockchain-api">main GitHub repository</a>.
+
+See <a href="https://docs.theblockchainapi.com">the docs</a> for more info.
+
+## Python Quick Start
+
+`pip install theblockchainapi`
+
+Get an API key pair at <a href="https://dashboard.theblockchainapi.com">dashboard.theblockchainapi.com</a>.
+
+`from theblockchainapi import TheBlockchainAPIResource`
+
+`result = TheBlockchainAPIResource("APIKeyID", "APISecretKey").generate_secret_key()`
+
+`print(result)`
+
+There are many examples using this package <a href="https://github.com/BL0CK-X/the-blockchain-api/tree/main/examples">here</a>.
+
+## Python Documentation
+
+To get a list of available functions, run `help(TheBlockchainAPIResource)` after importing `TheBlockchainAPIResource` as shown above.
+
+## Documentation
+
+For full API documentation, check out <a href="https://docs.theblockchainapi.com">the docs</a>.
+
+
+
+
+%prep
+%autosetup -n theblockchainapi-0.0.604
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-theblockchainapi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.604-1
+- Package Spec generated