summaryrefslogtreecommitdiff
path: root/python-thrift-pyi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-thrift-pyi.spec')
-rw-r--r--python-thrift-pyi.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-thrift-pyi.spec b/python-thrift-pyi.spec
new file mode 100644
index 0000000..cd03f70
--- /dev/null
+++ b/python-thrift-pyi.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-thrift-pyi
+Version: 0.5.0
+Release: 1
+Summary: This is simple `.pyi` stubs generator from thrift interfaces
+License: MIT
+URL: https://github.com/unmade/thrift-pyi
+Source0: https://mirrors.aliyun.com/pypi/web/packages/15/ac/d5360d45a1e294f012321d91d29cdc4449d1661f1b1627a338daed9af85e/thrift_pyi-0.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-astunparse
+Requires: python3-autoflake
+Requires: python3-black
+Requires: python3-thriftpy2
+
+%description
+
+
+%package -n python3-thrift-pyi
+Summary: This is simple `.pyi` stubs generator from thrift interfaces
+Provides: python-thrift-pyi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-thrift-pyi
+
+
+%package help
+Summary: Development documents and examples for thrift-pyi
+Provides: python3-thrift-pyi-doc
+%description help
+
+
+%prep
+%autosetup -n thrift_pyi-0.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-thrift-pyi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
+- Package Spec generated