summaryrefslogtreecommitdiff
path: root/python-timeboard.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-timeboard.spec')
-rw-r--r--python-timeboard.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-timeboard.spec b/python-timeboard.spec
new file mode 100644
index 0000000..efb4dcc
--- /dev/null
+++ b/python-timeboard.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-timeboard
+Version: 0.2.4
+Release: 1
+Summary: Calendar calculations over business days and work shifts
+License: BSD 3-Clause
+URL: http://timeboard.readthedocs.io
+Source0: https://mirrors.aliyun.com/pypi/web/packages/05/cc/b44334e99fbccbc75aabbe7800c248a664deab44549e6d2de4d6d47a5789/timeboard-0.2.4.tar.gz
+BuildArch: noarch
+
+
+%description
+ pip install timeboard
+timeboard is tested with Python versions 2.7, 3.6 - 3.10.
+Dependencies:
+- pandas >= 0.22
+- numpy >= 1.13
+- dateutil >= 2.6.1
+- six >= 1.11
+The import statement to run all the examples:
+ >>> import timeboard as tb
+
+%package -n python3-timeboard
+Summary: Calendar calculations over business days and work shifts
+Provides: python-timeboard
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-timeboard
+ pip install timeboard
+timeboard is tested with Python versions 2.7, 3.6 - 3.10.
+Dependencies:
+- pandas >= 0.22
+- numpy >= 1.13
+- dateutil >= 2.6.1
+- six >= 1.11
+The import statement to run all the examples:
+ >>> import timeboard as tb
+
+%package help
+Summary: Development documents and examples for timeboard
+Provides: python3-timeboard-doc
+%description help
+ pip install timeboard
+timeboard is tested with Python versions 2.7, 3.6 - 3.10.
+Dependencies:
+- pandas >= 0.22
+- numpy >= 1.13
+- dateutil >= 2.6.1
+- six >= 1.11
+The import statement to run all the examples:
+ >>> import timeboard as tb
+
+%prep
+%autosetup -n timeboard-0.2.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-timeboard -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.4-1
+- Package Spec generated