summaryrefslogtreecommitdiff
path: root/python-toga-core.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-toga-core.spec')
-rw-r--r--python-toga-core.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-toga-core.spec b/python-toga-core.spec
new file mode 100644
index 0000000..5f7712d
--- /dev/null
+++ b/python-toga-core.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-toga-core
+Version: 0.3.1
+Release: 1
+Summary: A Python native, OS native GUI toolkit.
+License: New BSD
+URL: https://beeware.org/project/projects/libraries/toga/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/17/621d3d0f2cf948de6611bf2a1d495b2052352a1bf38a331dc55ca76a5b26/toga-core-0.3.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-travertino
+Requires: python3-importlib-metadata
+Requires: python3-coverage[toml]
+Requires: python3-pytest
+Requires: python3-pytest-tldr
+Requires: python3-setuptools-scm[toml]
+Requires: python3-tox
+Requires: python3-pre-commit
+Requires: python3-pre-commit
+Requires: python3-furo
+Requires: python3-pyenchant
+Requires: python3-sphinx
+Requires: python3-sphinx-tabs
+Requires: python3-sphinx-autobuild
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-sphinx-csv-filter
+Requires: python3-sphinxcontrib-spelling
+
+%description
+A Python native, OS native GUI toolkit.
+
+%package -n python3-toga-core
+Summary: A Python native, OS native GUI toolkit.
+Provides: python-toga-core
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-toga-core
+A Python native, OS native GUI toolkit.
+
+%package help
+Summary: Development documents and examples for toga-core
+Provides: python3-toga-core-doc
+%description help
+A Python native, OS native GUI toolkit.
+
+%prep
+%autosetup -n toga-core-0.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-toga-core -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
+- Package Spec generated