summaryrefslogtreecommitdiff
path: root/python-tohu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tohu.spec')
-rw-r--r--python-tohu.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-tohu.spec b/python-tohu.spec
new file mode 100644
index 0000000..9c0aa76
--- /dev/null
+++ b/python-tohu.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tohu
+Version: 0.6.7
+Release: 1
+Summary: Create random data in a controllable way
+License: MIT
+URL: https://github.com/maxalbert/tohu
+Source0: https://mirrors.aliyun.com/pypi/web/packages/03/30/c885ee03a9193e31e4bcf1e392ec01565660691cafbbe64aee584e97388c/tohu-0.6.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-attrs
+Requires: python3-bidict
+Requires: python3-faker
+Requires: python3-geojson
+Requires: python3-pandas
+Requires: python3-psycopg2-binary
+Requires: python3-shapely
+Requires: python3-sqlalchemy
+Requires: python3-tqdm
+Requires: python3-ipython
+Requires: python3-jupyter
+Requires: python3-pytest
+Requires: python3-nbval
+
+%description
+
+
+%package -n python3-tohu
+Summary: Create random data in a controllable way
+Provides: python-tohu
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tohu
+
+
+%package help
+Summary: Development documents and examples for tohu
+Provides: python3-tohu-doc
+%description help
+
+
+%prep
+%autosetup -n tohu-0.6.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tohu -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.7-1
+- Package Spec generated