summaryrefslogtreecommitdiff
path: root/python-tradocs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tradocs.spec')
-rw-r--r--python-tradocs.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/python-tradocs.spec b/python-tradocs.spec
new file mode 100644
index 0000000..8c1d8ed
--- /dev/null
+++ b/python-tradocs.spec
@@ -0,0 +1,112 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tradocs
+Version: 1.5.1
+Release: 1
+Summary: DocFX localization
+License: MIT
+URL: https://github.com/eberjoe/tradocs
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/86/85cea6c7a40c3576191bc7275d5d40c7ff6508bde47c74ab842e752dc6cb/tradocs-1.5.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Click
+Requires: python3-gitpython
+Requires: python3-requests
+Requires: python3-colorama
+
+%description
+# Translation of Source Code for DocFX Websites
+
+This tool translates DocFX's Markdown and Yaml source code to foreign languages, preserving markup sintax.
+
+Install Python 3, then install this package with the following command:
+
+```pip install tradocs```
+
+Type ```tradocs``` on the command line to see the options.
+
+Powered by [Yandex.Translate](http://translate.yandex.com)
+
+
+
+%package -n python3-tradocs
+Summary: DocFX localization
+Provides: python-tradocs
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tradocs
+# Translation of Source Code for DocFX Websites
+
+This tool translates DocFX's Markdown and Yaml source code to foreign languages, preserving markup sintax.
+
+Install Python 3, then install this package with the following command:
+
+```pip install tradocs```
+
+Type ```tradocs``` on the command line to see the options.
+
+Powered by [Yandex.Translate](http://translate.yandex.com)
+
+
+
+%package help
+Summary: Development documents and examples for tradocs
+Provides: python3-tradocs-doc
+%description help
+# Translation of Source Code for DocFX Websites
+
+This tool translates DocFX's Markdown and Yaml source code to foreign languages, preserving markup sintax.
+
+Install Python 3, then install this package with the following command:
+
+```pip install tradocs```
+
+Type ```tradocs``` on the command line to see the options.
+
+Powered by [Yandex.Translate](http://translate.yandex.com)
+
+
+
+%prep
+%autosetup -n tradocs-1.5.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tradocs -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.1-1
+- Package Spec generated