summaryrefslogtreecommitdiff
path: root/python-trytond-analytic-account.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 09:14:04 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 09:14:04 +0000
commit3f3d9c56bec37514e375b2cc624b785b2363891b (patch)
tree6c5b63730c4448a222e361dbc789d0682b3598d3 /python-trytond-analytic-account.spec
parente788a8573ed2d7028d33f6ac6db5eff6c15f3093 (diff)
automatic import of python-trytond-analytic-account
Diffstat (limited to 'python-trytond-analytic-account.spec')
-rw-r--r--python-trytond-analytic-account.spec259
1 files changed, 259 insertions, 0 deletions
diff --git a/python-trytond-analytic-account.spec b/python-trytond-analytic-account.spec
new file mode 100644
index 0000000..b8e72a1
--- /dev/null
+++ b/python-trytond-analytic-account.spec
@@ -0,0 +1,259 @@
+%global _empty_manifest_terminate_build 0
+Name: python-trytond-analytic-account
+Version: 6.8.0
+Release: 1
+Summary: Tryton module for analytic accounting
+License: GPL-3
+URL: http://www.tryton.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4a/7c/b35958850e251311c14439feed7f22c7ed10b94d2753e39c52e4d9e460d4/trytond_analytic_account-6.8.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-sql
+Requires: python3-trytond-account
+Requires: python3-trytond-company
+Requires: python3-trytond-currency
+Requires: python3-trytond-party
+Requires: python3-trytond
+Requires: python3-proteus
+
+%description
+Analytic Account Module
+#######################
+
+The analytic account module adds the fundamentals required to analyse
+accounting using multiple different axes.
+
+A chart of analytic accounts can be setup for each axis.
+
+Account
+*******
+
+An analytic account is defined by these fields:
+
+- Name
+- Code
+- Company
+- Type:
+
+ - Root: define an axis
+ - View: sum amounts of children accounts
+ - Normal: store analytic lines
+ - Distribution: distribute linked lines between different accounts
+
+- Parent
+- Balance/Credit/Debit
+- State:
+
+ - Draft
+ - Opened
+ - Closed
+
+- Note
+
+Line
+****
+
+An analytic line defines the amount of money from a move line to be assigned to
+an analytic account. It contains the following fields:
+
+- Debit/Credit
+- Account
+- Move Line
+- Date
+
+When the linked move is posted, an analytic state is calculated for each of the
+move lines. It is only valid if all the analytic axes have been completely
+filled.
+The incomplete lines can be found in the menu entry "Analytic Lines to
+Complete".
+
+Rule
+****
+
+The module contains a rule engine that can automatically create analytic lines
+when the move is posted, but only if they do not already have analytic lines.
+The criteria for the rule engine are:
+
+- Account
+- Party
+- Journal
+
+
+%package -n python3-trytond-analytic-account
+Summary: Tryton module for analytic accounting
+Provides: python-trytond-analytic-account
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-trytond-analytic-account
+Analytic Account Module
+#######################
+
+The analytic account module adds the fundamentals required to analyse
+accounting using multiple different axes.
+
+A chart of analytic accounts can be setup for each axis.
+
+Account
+*******
+
+An analytic account is defined by these fields:
+
+- Name
+- Code
+- Company
+- Type:
+
+ - Root: define an axis
+ - View: sum amounts of children accounts
+ - Normal: store analytic lines
+ - Distribution: distribute linked lines between different accounts
+
+- Parent
+- Balance/Credit/Debit
+- State:
+
+ - Draft
+ - Opened
+ - Closed
+
+- Note
+
+Line
+****
+
+An analytic line defines the amount of money from a move line to be assigned to
+an analytic account. It contains the following fields:
+
+- Debit/Credit
+- Account
+- Move Line
+- Date
+
+When the linked move is posted, an analytic state is calculated for each of the
+move lines. It is only valid if all the analytic axes have been completely
+filled.
+The incomplete lines can be found in the menu entry "Analytic Lines to
+Complete".
+
+Rule
+****
+
+The module contains a rule engine that can automatically create analytic lines
+when the move is posted, but only if they do not already have analytic lines.
+The criteria for the rule engine are:
+
+- Account
+- Party
+- Journal
+
+
+%package help
+Summary: Development documents and examples for trytond-analytic-account
+Provides: python3-trytond-analytic-account-doc
+%description help
+Analytic Account Module
+#######################
+
+The analytic account module adds the fundamentals required to analyse
+accounting using multiple different axes.
+
+A chart of analytic accounts can be setup for each axis.
+
+Account
+*******
+
+An analytic account is defined by these fields:
+
+- Name
+- Code
+- Company
+- Type:
+
+ - Root: define an axis
+ - View: sum amounts of children accounts
+ - Normal: store analytic lines
+ - Distribution: distribute linked lines between different accounts
+
+- Parent
+- Balance/Credit/Debit
+- State:
+
+ - Draft
+ - Opened
+ - Closed
+
+- Note
+
+Line
+****
+
+An analytic line defines the amount of money from a move line to be assigned to
+an analytic account. It contains the following fields:
+
+- Debit/Credit
+- Account
+- Move Line
+- Date
+
+When the linked move is posted, an analytic state is calculated for each of the
+move lines. It is only valid if all the analytic axes have been completely
+filled.
+The incomplete lines can be found in the menu entry "Analytic Lines to
+Complete".
+
+Rule
+****
+
+The module contains a rule engine that can automatically create analytic lines
+when the move is posted, but only if they do not already have analytic lines.
+The criteria for the rule engine are:
+
+- Account
+- Party
+- Journal
+
+
+%prep
+%autosetup -n trytond-analytic-account-6.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-trytond-analytic-account -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 6.8.0-1
+- Package Spec generated