summaryrefslogtreecommitdiff
path: root/python-turtlsystems.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-turtlsystems.spec')
-rw-r--r--python-turtlsystems.spec244
1 files changed, 244 insertions, 0 deletions
diff --git a/python-turtlsystems.spec b/python-turtlsystems.spec
new file mode 100644
index 0000000..c3a3444
--- /dev/null
+++ b/python-turtlsystems.spec
@@ -0,0 +1,244 @@
+%global _empty_manifest_terminate_build 0
+Name: python-TurtLSystems
+Version: 0.1.7
+Release: 1
+Summary: Tool to draw L-systems via turtle graphics and save them as pngs and gifs.
+License: MIT
+URL: https://github.com/discretegames/TurtLSystems
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/93/1b/7090e4a32fbaf8bb4f258e22fb284fdee693d756aca926669c5d0a0a03e0/TurtLSystems-0.1.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-Pillow
+
+%description
+Generalized versions of all the examples above and more are available in
+[examples.py][expy] which can be imported and run with:
+```py
+from TurtLSystems.examples import *
+sierpinski_triangle()
+# sierpinski_arrowhead()
+# square_koch_curve()
+# koch_snowflake()
+# koch_snowflake(anti=True)
+# dragon_curve()
+# cantor_set()
+# tree()
+# plant()
+# gradient()
+```
+Simply uncomment the desired examples and run the file.
+The exact examples present in this readme can be found all in one place [here][rexpy].
+# Links
+[TurtLSystems PyPI Package Page][pypi]
+[TurtLSystems GitHub Repo][gh]
+[TurtLSystems License][license]
+[L-Systems Wikipedia][wiki]
+[Ghostscript][gs]
+[Pillow][pillow]
+[pypi]: https://pypi.org/project/TurtLSystems/
+[tpypi]: https://test.pypi.org/project/TurtLSystems/
+[wiki]: https://en.wikipedia.org/wiki/L-system
+[turtle]: https://docs.python.org/3/library/turtle.html
+[gs]: https://ghostscript.com/
+[gsd]: https://ghostscript.com/releases/gsdnld.html
+[gh]: https://github.com/discretegames/TurtLSystems
+[init]: https://github.com/discretegames/TurtLSystems#init-function
+[draw]: https://github.com/discretegames/TurtLSystems#draw-function
+[wait]: https://github.com/discretegames/TurtLSystems#wait-function
+[lsystem]: https://github.com/discretegames/TurtLSystems#lsystem-function
+[intro]: https://github.com/discretegames/TurtLSystems#turtlsystems
+[install]: https://github.com/discretegames/TurtLSystems#installation-supports-python-36
+[usage]: https://github.com/discretegames/TurtLSystems#usage
+[links]: https://github.com/discretegames/TurtLSystems#links
+[ex]: https://github.com/discretegames/TurtLSystems#examples
+[inst]: https://github.com/discretegames/TurtLSystems#l-system-instructions
+[py]: https://www.python.org/downloads/
+[paul]: http://paulbourke.net/fractals/lsys
+[license]: https://github.com/discretegames/TurtLSystems/blob/main/LICENSE.txt
+[pillow]: https://pypi.org/project/Pillow/
+[pillowdoc]: https://pillow.readthedocs.io/en/stable/
+[arrowheadwiki]: https://en.wikipedia.org/wiki/Sierpi%C5%84ski_curve#Arrowhead_curve
+[example]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/example.gif
+[sierpinski]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/sierpinski.png
+[arrowhead]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/arrowhead.png
+[koch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/koch.png
+[antikoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/antikoch.png
+[squarekoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/squarekoch.png
+[dragon]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/dragon.png
+[tree]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/tree.png
+[plant]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/plant.png
+[expy]: https://github.com/discretegames/TurtLSystems/blob/main/src/TurtLSystems/examples.py
+[rexpy]: https://github.com/discretegames/TurtLSystems/blob/main/examples/readme_examples.py
+
+%package -n python3-TurtLSystems
+Summary: Tool to draw L-systems via turtle graphics and save them as pngs and gifs.
+Provides: python-TurtLSystems
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-TurtLSystems
+Generalized versions of all the examples above and more are available in
+[examples.py][expy] which can be imported and run with:
+```py
+from TurtLSystems.examples import *
+sierpinski_triangle()
+# sierpinski_arrowhead()
+# square_koch_curve()
+# koch_snowflake()
+# koch_snowflake(anti=True)
+# dragon_curve()
+# cantor_set()
+# tree()
+# plant()
+# gradient()
+```
+Simply uncomment the desired examples and run the file.
+The exact examples present in this readme can be found all in one place [here][rexpy].
+# Links
+[TurtLSystems PyPI Package Page][pypi]
+[TurtLSystems GitHub Repo][gh]
+[TurtLSystems License][license]
+[L-Systems Wikipedia][wiki]
+[Ghostscript][gs]
+[Pillow][pillow]
+[pypi]: https://pypi.org/project/TurtLSystems/
+[tpypi]: https://test.pypi.org/project/TurtLSystems/
+[wiki]: https://en.wikipedia.org/wiki/L-system
+[turtle]: https://docs.python.org/3/library/turtle.html
+[gs]: https://ghostscript.com/
+[gsd]: https://ghostscript.com/releases/gsdnld.html
+[gh]: https://github.com/discretegames/TurtLSystems
+[init]: https://github.com/discretegames/TurtLSystems#init-function
+[draw]: https://github.com/discretegames/TurtLSystems#draw-function
+[wait]: https://github.com/discretegames/TurtLSystems#wait-function
+[lsystem]: https://github.com/discretegames/TurtLSystems#lsystem-function
+[intro]: https://github.com/discretegames/TurtLSystems#turtlsystems
+[install]: https://github.com/discretegames/TurtLSystems#installation-supports-python-36
+[usage]: https://github.com/discretegames/TurtLSystems#usage
+[links]: https://github.com/discretegames/TurtLSystems#links
+[ex]: https://github.com/discretegames/TurtLSystems#examples
+[inst]: https://github.com/discretegames/TurtLSystems#l-system-instructions
+[py]: https://www.python.org/downloads/
+[paul]: http://paulbourke.net/fractals/lsys
+[license]: https://github.com/discretegames/TurtLSystems/blob/main/LICENSE.txt
+[pillow]: https://pypi.org/project/Pillow/
+[pillowdoc]: https://pillow.readthedocs.io/en/stable/
+[arrowheadwiki]: https://en.wikipedia.org/wiki/Sierpi%C5%84ski_curve#Arrowhead_curve
+[example]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/example.gif
+[sierpinski]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/sierpinski.png
+[arrowhead]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/arrowhead.png
+[koch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/koch.png
+[antikoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/antikoch.png
+[squarekoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/squarekoch.png
+[dragon]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/dragon.png
+[tree]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/tree.png
+[plant]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/plant.png
+[expy]: https://github.com/discretegames/TurtLSystems/blob/main/src/TurtLSystems/examples.py
+[rexpy]: https://github.com/discretegames/TurtLSystems/blob/main/examples/readme_examples.py
+
+%package help
+Summary: Development documents and examples for TurtLSystems
+Provides: python3-TurtLSystems-doc
+%description help
+Generalized versions of all the examples above and more are available in
+[examples.py][expy] which can be imported and run with:
+```py
+from TurtLSystems.examples import *
+sierpinski_triangle()
+# sierpinski_arrowhead()
+# square_koch_curve()
+# koch_snowflake()
+# koch_snowflake(anti=True)
+# dragon_curve()
+# cantor_set()
+# tree()
+# plant()
+# gradient()
+```
+Simply uncomment the desired examples and run the file.
+The exact examples present in this readme can be found all in one place [here][rexpy].
+# Links
+[TurtLSystems PyPI Package Page][pypi]
+[TurtLSystems GitHub Repo][gh]
+[TurtLSystems License][license]
+[L-Systems Wikipedia][wiki]
+[Ghostscript][gs]
+[Pillow][pillow]
+[pypi]: https://pypi.org/project/TurtLSystems/
+[tpypi]: https://test.pypi.org/project/TurtLSystems/
+[wiki]: https://en.wikipedia.org/wiki/L-system
+[turtle]: https://docs.python.org/3/library/turtle.html
+[gs]: https://ghostscript.com/
+[gsd]: https://ghostscript.com/releases/gsdnld.html
+[gh]: https://github.com/discretegames/TurtLSystems
+[init]: https://github.com/discretegames/TurtLSystems#init-function
+[draw]: https://github.com/discretegames/TurtLSystems#draw-function
+[wait]: https://github.com/discretegames/TurtLSystems#wait-function
+[lsystem]: https://github.com/discretegames/TurtLSystems#lsystem-function
+[intro]: https://github.com/discretegames/TurtLSystems#turtlsystems
+[install]: https://github.com/discretegames/TurtLSystems#installation-supports-python-36
+[usage]: https://github.com/discretegames/TurtLSystems#usage
+[links]: https://github.com/discretegames/TurtLSystems#links
+[ex]: https://github.com/discretegames/TurtLSystems#examples
+[inst]: https://github.com/discretegames/TurtLSystems#l-system-instructions
+[py]: https://www.python.org/downloads/
+[paul]: http://paulbourke.net/fractals/lsys
+[license]: https://github.com/discretegames/TurtLSystems/blob/main/LICENSE.txt
+[pillow]: https://pypi.org/project/Pillow/
+[pillowdoc]: https://pillow.readthedocs.io/en/stable/
+[arrowheadwiki]: https://en.wikipedia.org/wiki/Sierpi%C5%84ski_curve#Arrowhead_curve
+[example]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/example.gif
+[sierpinski]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/sierpinski.png
+[arrowhead]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/arrowhead.png
+[koch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/koch.png
+[antikoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/antikoch.png
+[squarekoch]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/squarekoch.png
+[dragon]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/dragon.png
+[tree]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/tree.png
+[plant]: https://raw.githubusercontent.com/discretegames/TurtLSystems/main/examples/plant.png
+[expy]: https://github.com/discretegames/TurtLSystems/blob/main/src/TurtLSystems/examples.py
+[rexpy]: https://github.com/discretegames/TurtLSystems/blob/main/examples/readme_examples.py
+
+%prep
+%autosetup -n TurtLSystems-0.1.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-TurtLSystems -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.7-1
+- Package Spec generated