summaryrefslogtreecommitdiff
path: root/python-ultimate-sitemap-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ultimate-sitemap-parser.spec')
-rw-r--r--python-ultimate-sitemap-parser.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/python-ultimate-sitemap-parser.spec b/python-ultimate-sitemap-parser.spec
new file mode 100644
index 0000000..f810146
--- /dev/null
+++ b/python-ultimate-sitemap-parser.spec
@@ -0,0 +1,118 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ultimate-sitemap-parser
+Version: 0.5
+Release: 1
+Summary: Ultimate Sitemap Parser
+License: GPLv3+
+URL: https://github.com/berkmancenter/mediacloud-ultimate_sitemap_parser
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/21/44/04eada3b1b1f825eb18b93e385ff652778c96902788b87a9b1e0a141ccff/ultimate_sitemap_parser-0.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-dateutil
+Requires: python3-requests
+Requires: python3-requests-mock
+Requires: python3-pytest
+
+%description
+- Supports all sitemap formats:
+ - `XML sitemaps <https://www.sitemaps.org/protocol.html#xmlTagDefinitions>`_
+ - `Google News sitemaps <https://support.google.com/news/publisher-center/answer/74288?hl=en>`_
+ - `plain text sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `RSS 2.0 / Atom 0.3 / Atom 1.0 sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `Sitemaps linked from robots.txt <https://developers.google.com/search/reference/robots_txt#sitemap>`_
+- Field-tested with ~1 million URLs as part of the `Media Cloud project <https://mediacloud.org/>`_
+- Error-tolerant with more common sitemap bugs
+- Tries to find sitemaps not listed in ``robots.txt``
+- Uses fast and memory efficient Expat XML parsing
+- Doesn't consume much memory even with massive sitemap hierarchies
+- Provides a generated sitemap tree as easy to use object tree
+- Supports using a custom web client
+- Uses a small number of actively maintained third-party modules
+- Reasonably tested
+
+%package -n python3-ultimate-sitemap-parser
+Summary: Ultimate Sitemap Parser
+Provides: python-ultimate-sitemap-parser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ultimate-sitemap-parser
+- Supports all sitemap formats:
+ - `XML sitemaps <https://www.sitemaps.org/protocol.html#xmlTagDefinitions>`_
+ - `Google News sitemaps <https://support.google.com/news/publisher-center/answer/74288?hl=en>`_
+ - `plain text sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `RSS 2.0 / Atom 0.3 / Atom 1.0 sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `Sitemaps linked from robots.txt <https://developers.google.com/search/reference/robots_txt#sitemap>`_
+- Field-tested with ~1 million URLs as part of the `Media Cloud project <https://mediacloud.org/>`_
+- Error-tolerant with more common sitemap bugs
+- Tries to find sitemaps not listed in ``robots.txt``
+- Uses fast and memory efficient Expat XML parsing
+- Doesn't consume much memory even with massive sitemap hierarchies
+- Provides a generated sitemap tree as easy to use object tree
+- Supports using a custom web client
+- Uses a small number of actively maintained third-party modules
+- Reasonably tested
+
+%package help
+Summary: Development documents and examples for ultimate-sitemap-parser
+Provides: python3-ultimate-sitemap-parser-doc
+%description help
+- Supports all sitemap formats:
+ - `XML sitemaps <https://www.sitemaps.org/protocol.html#xmlTagDefinitions>`_
+ - `Google News sitemaps <https://support.google.com/news/publisher-center/answer/74288?hl=en>`_
+ - `plain text sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `RSS 2.0 / Atom 0.3 / Atom 1.0 sitemaps <https://www.sitemaps.org/protocol.html#otherformats>`_
+ - `Sitemaps linked from robots.txt <https://developers.google.com/search/reference/robots_txt#sitemap>`_
+- Field-tested with ~1 million URLs as part of the `Media Cloud project <https://mediacloud.org/>`_
+- Error-tolerant with more common sitemap bugs
+- Tries to find sitemaps not listed in ``robots.txt``
+- Uses fast and memory efficient Expat XML parsing
+- Doesn't consume much memory even with massive sitemap hierarchies
+- Provides a generated sitemap tree as easy to use object tree
+- Supports using a custom web client
+- Uses a small number of actively maintained third-party modules
+- Reasonably tested
+
+%prep
+%autosetup -n ultimate-sitemap-parser-0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ultimate-sitemap-parser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5-1
+- Package Spec generated