summaryrefslogtreecommitdiff
path: root/python-umapi-client.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-umapi-client.spec')
-rw-r--r--python-umapi-client.spec294
1 files changed, 294 insertions, 0 deletions
diff --git a/python-umapi-client.spec b/python-umapi-client.spec
new file mode 100644
index 0000000..2c11833
--- /dev/null
+++ b/python-umapi-client.spec
@@ -0,0 +1,294 @@
+%global _empty_manifest_terminate_build 0
+Name: python-umapi-client
+Version: 2.22
+Release: 1
+Summary: Client for the User Management API (UMAPI) from Adobe - see https://adobe.ly/2h1pHgV
+License: MIT
+URL: https://github.com/adobe-apiplatform/umapi-client.py/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/48/7b/7ef6941b1fd1004ca4ef6ccf47e1376dcaf53efc096c35a3ee65df5b4b6f/umapi_client-2.22.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-cryptography
+Requires: python3-PyJWT
+
+%description
+# umapi-client.py
+
+This is a Python client for the User Management API from Adobe, aka the
+[UMAPI](https://www.adobe.io/products/usermanagement/docs/gettingstarted.html).
+
+The User Management API is an Adobe-hosted network service
+which provides Adobe Enterprise customers the ability to manage their users. This
+client makes it easy to access the UMAPI from a local Python application.
+
+This client is open source, maintained by Adobe, and distributed under the terms
+of the OSI-approved MIT license. Copyright (c) 2016-2021 Adobe Inc.
+
+# Installation
+
+`umapi-client.py` is published to the Python Packaging Index.
+
+https://pypi.org/project/umapi-client/
+
+It can be installed with pip:
+
+```
+$ pip install umapi-client
+```
+
+Or a dependency manager such as Poetry:
+
+```
+$ poetry add umapi-client
+```
+
+# Building
+
+[Poetry](https://python-poetry.org/) is required to build the package. Follow the instructions documented on
+Poetry's website to install it on your system.
+
+1. Clone this repository
+ ```
+ $ git clone https://github.com/adobe-apiplatform/umapi-client.py
+ $ cd umapi-client.py
+ ```
+
+2. Install dependencies to virtual environment.
+ ```
+ $ poetry install
+ ```
+
+3. The `build` command will create a source package (`.tar.gz`) and a wheel file (`.whl`) in the `dist` directory.
+ ```
+ $ poetry build
+ $ ls dist
+ umapi-client-2.18.tar.gz umapi_client-2.18-py3-none-any.whl
+ ```
+
+4. Some of the packages required by this module use encryption, and so may
+ require you to do local builds of modules that use SSL. Typically, this
+ will require you to have a python installed that supports compiling
+ extensions.
+
+5. Run tests with `pytest`.
+ ```
+ $ poetry run pytest
+ ```
+
+# Usage
+
+Usage documentation, as well as information about how to get client
+credentials for use of the UMAPI, can be found in the
+[user guide](https://adobe-apiplatform.github.io/umapi-client.py/),
+whose sources are in the `docs` directory of this repository.
+
+# License
+
+This project is licensed under the MIT License. See [LICENSE](LICENSE) for more information.
+
+
+%package -n python3-umapi-client
+Summary: Client for the User Management API (UMAPI) from Adobe - see https://adobe.ly/2h1pHgV
+Provides: python-umapi-client
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-umapi-client
+# umapi-client.py
+
+This is a Python client for the User Management API from Adobe, aka the
+[UMAPI](https://www.adobe.io/products/usermanagement/docs/gettingstarted.html).
+
+The User Management API is an Adobe-hosted network service
+which provides Adobe Enterprise customers the ability to manage their users. This
+client makes it easy to access the UMAPI from a local Python application.
+
+This client is open source, maintained by Adobe, and distributed under the terms
+of the OSI-approved MIT license. Copyright (c) 2016-2021 Adobe Inc.
+
+# Installation
+
+`umapi-client.py` is published to the Python Packaging Index.
+
+https://pypi.org/project/umapi-client/
+
+It can be installed with pip:
+
+```
+$ pip install umapi-client
+```
+
+Or a dependency manager such as Poetry:
+
+```
+$ poetry add umapi-client
+```
+
+# Building
+
+[Poetry](https://python-poetry.org/) is required to build the package. Follow the instructions documented on
+Poetry's website to install it on your system.
+
+1. Clone this repository
+ ```
+ $ git clone https://github.com/adobe-apiplatform/umapi-client.py
+ $ cd umapi-client.py
+ ```
+
+2. Install dependencies to virtual environment.
+ ```
+ $ poetry install
+ ```
+
+3. The `build` command will create a source package (`.tar.gz`) and a wheel file (`.whl`) in the `dist` directory.
+ ```
+ $ poetry build
+ $ ls dist
+ umapi-client-2.18.tar.gz umapi_client-2.18-py3-none-any.whl
+ ```
+
+4. Some of the packages required by this module use encryption, and so may
+ require you to do local builds of modules that use SSL. Typically, this
+ will require you to have a python installed that supports compiling
+ extensions.
+
+5. Run tests with `pytest`.
+ ```
+ $ poetry run pytest
+ ```
+
+# Usage
+
+Usage documentation, as well as information about how to get client
+credentials for use of the UMAPI, can be found in the
+[user guide](https://adobe-apiplatform.github.io/umapi-client.py/),
+whose sources are in the `docs` directory of this repository.
+
+# License
+
+This project is licensed under the MIT License. See [LICENSE](LICENSE) for more information.
+
+
+%package help
+Summary: Development documents and examples for umapi-client
+Provides: python3-umapi-client-doc
+%description help
+# umapi-client.py
+
+This is a Python client for the User Management API from Adobe, aka the
+[UMAPI](https://www.adobe.io/products/usermanagement/docs/gettingstarted.html).
+
+The User Management API is an Adobe-hosted network service
+which provides Adobe Enterprise customers the ability to manage their users. This
+client makes it easy to access the UMAPI from a local Python application.
+
+This client is open source, maintained by Adobe, and distributed under the terms
+of the OSI-approved MIT license. Copyright (c) 2016-2021 Adobe Inc.
+
+# Installation
+
+`umapi-client.py` is published to the Python Packaging Index.
+
+https://pypi.org/project/umapi-client/
+
+It can be installed with pip:
+
+```
+$ pip install umapi-client
+```
+
+Or a dependency manager such as Poetry:
+
+```
+$ poetry add umapi-client
+```
+
+# Building
+
+[Poetry](https://python-poetry.org/) is required to build the package. Follow the instructions documented on
+Poetry's website to install it on your system.
+
+1. Clone this repository
+ ```
+ $ git clone https://github.com/adobe-apiplatform/umapi-client.py
+ $ cd umapi-client.py
+ ```
+
+2. Install dependencies to virtual environment.
+ ```
+ $ poetry install
+ ```
+
+3. The `build` command will create a source package (`.tar.gz`) and a wheel file (`.whl`) in the `dist` directory.
+ ```
+ $ poetry build
+ $ ls dist
+ umapi-client-2.18.tar.gz umapi_client-2.18-py3-none-any.whl
+ ```
+
+4. Some of the packages required by this module use encryption, and so may
+ require you to do local builds of modules that use SSL. Typically, this
+ will require you to have a python installed that supports compiling
+ extensions.
+
+5. Run tests with `pytest`.
+ ```
+ $ poetry run pytest
+ ```
+
+# Usage
+
+Usage documentation, as well as information about how to get client
+credentials for use of the UMAPI, can be found in the
+[user guide](https://adobe-apiplatform.github.io/umapi-client.py/),
+whose sources are in the `docs` directory of this repository.
+
+# License
+
+This project is licensed under the MIT License. See [LICENSE](LICENSE) for more information.
+
+
+%prep
+%autosetup -n umapi-client-2.22
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-umapi-client -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.22-1
+- Package Spec generated