summaryrefslogtreecommitdiff
path: root/python-uploadfu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-uploadfu.spec')
-rw-r--r--python-uploadfu.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-uploadfu.spec b/python-uploadfu.spec
new file mode 100644
index 0000000..620f534
--- /dev/null
+++ b/python-uploadfu.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-UploadFu
+Version: 0.5
+Release: 1
+Summary: Bittorrent upload tools for win32
+License: UNKNOWN
+URL: UNKNOWN
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/4d/f5450d806ed62ce52f32c9fa32981611031997238b2c1142286c8a78859f/UploadFu-0.5.zip
+BuildArch: noarch
+
+
+%description
+- torrent creation and uploading according to configuration files
+- directory watching and automatic uploading of new files that are moved
+ there
+- a context menu to access all those fetures
+
+%package -n python3-UploadFu
+Summary: Bittorrent upload tools for win32
+Provides: python-UploadFu
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-UploadFu
+- torrent creation and uploading according to configuration files
+- directory watching and automatic uploading of new files that are moved
+ there
+- a context menu to access all those fetures
+
+%package help
+Summary: Development documents and examples for UploadFu
+Provides: python3-UploadFu-doc
+%description help
+- torrent creation and uploading according to configuration files
+- directory watching and automatic uploading of new files that are moved
+ there
+- a context menu to access all those fetures
+
+%prep
+%autosetup -n UploadFu-0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-UploadFu -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5-1
+- Package Spec generated