summaryrefslogtreecommitdiff
path: root/python-upt-cpan.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 17:47:47 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 17:47:47 +0000
commitaa498ca71bee1c94396aa7d02b6f038f288bb21a (patch)
treeae301b9ca74bac3dacbe57214c39c6469e740580 /python-upt-cpan.spec
parentb830e76a92624b811543b4394f0c6ffa28da2071 (diff)
automatic import of python-upt-cpan
Diffstat (limited to 'python-upt-cpan.spec')
-rw-r--r--python-upt-cpan.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-upt-cpan.spec b/python-upt-cpan.spec
new file mode 100644
index 0000000..bd01e16
--- /dev/null
+++ b/python-upt-cpan.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-upt-cpan
+Version: 0.6.1
+Release: 1
+Summary: CPAN frontend for upt
+License: BSD License
+URL: https://framagit.org/upt/upt-cpan
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/33/d7/c61427214a8992d151e97df61b9265997eeb3bfe56dee6a98d3879263bcf/upt-cpan-0.6.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-upt
+Requires: python3-requests-mock
+
+%description
+# Universal Packaging Tool: CPAN frontend
+This is a [CPAN](https://www.cpan.org/) frontend for [upt](https://pypi.python.org/pypi/upt).
+
+
+
+
+%package -n python3-upt-cpan
+Summary: CPAN frontend for upt
+Provides: python-upt-cpan
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-upt-cpan
+# Universal Packaging Tool: CPAN frontend
+This is a [CPAN](https://www.cpan.org/) frontend for [upt](https://pypi.python.org/pypi/upt).
+
+
+
+
+%package help
+Summary: Development documents and examples for upt-cpan
+Provides: python3-upt-cpan-doc
+%description help
+# Universal Packaging Tool: CPAN frontend
+This is a [CPAN](https://www.cpan.org/) frontend for [upt](https://pypi.python.org/pypi/upt).
+
+
+
+
+%prep
+%autosetup -n upt-cpan-0.6.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-upt-cpan -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.1-1
+- Package Spec generated