summaryrefslogtreecommitdiff
path: root/python-uvloop.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-uvloop.spec')
-rw-r--r--python-uvloop.spec117
1 files changed, 117 insertions, 0 deletions
diff --git a/python-uvloop.spec b/python-uvloop.spec
new file mode 100644
index 0000000..363f39b
--- /dev/null
+++ b/python-uvloop.spec
@@ -0,0 +1,117 @@
+%global _empty_manifest_terminate_build 0
+Name: python-uvloop
+Version: 0.17.0
+Release: 1
+Summary: Fast implementation of asyncio event loop on top of libuv
+License: MIT
+URL: http://github.com/MagicStack/uvloop
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/86/6dda1760481abf244cbd3908b79a4520d757040ca9ec37a79fc0fd01e2a0/uvloop-0.17.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Cython
+Requires: python3-pytest
+Requires: python3-Sphinx
+Requires: python3-sphinxcontrib-asyncio
+Requires: python3-sphinx-rtd-theme
+Requires: python3-flake8
+Requires: python3-psutil
+Requires: python3-pycodestyle
+Requires: python3-pyOpenSSL
+Requires: python3-mypy
+Requires: python3-aiohttp
+Requires: python3-Sphinx
+Requires: python3-sphinxcontrib-asyncio
+Requires: python3-sphinx-rtd-theme
+Requires: python3-flake8
+Requires: python3-psutil
+Requires: python3-pycodestyle
+Requires: python3-pyOpenSSL
+Requires: python3-mypy
+Requires: python3-Cython
+Requires: python3-aiohttp
+
+%description
+uvloop makes asyncio 2-4x faster.
+The above chart shows the performance of an echo server with different
+message sizes. The *sockets* benchmark uses ``loop.sock_recv()`` and
+``loop.sock_sendall()`` methods; the *streams* benchmark uses asyncio
+high-level streams, created by the ``asyncio.start_server()`` function;
+and the *protocol* benchmark uses ``loop.create_server()`` with a simple
+echo protocol. Read more about uvloop in a
+`blog post <http://magic.io/blog/uvloop-blazing-fast-python-networking/>`_
+about it.
+
+%package -n python3-uvloop
+Summary: Fast implementation of asyncio event loop on top of libuv
+Provides: python-uvloop
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-uvloop
+uvloop makes asyncio 2-4x faster.
+The above chart shows the performance of an echo server with different
+message sizes. The *sockets* benchmark uses ``loop.sock_recv()`` and
+``loop.sock_sendall()`` methods; the *streams* benchmark uses asyncio
+high-level streams, created by the ``asyncio.start_server()`` function;
+and the *protocol* benchmark uses ``loop.create_server()`` with a simple
+echo protocol. Read more about uvloop in a
+`blog post <http://magic.io/blog/uvloop-blazing-fast-python-networking/>`_
+about it.
+
+%package help
+Summary: Development documents and examples for uvloop
+Provides: python3-uvloop-doc
+%description help
+uvloop makes asyncio 2-4x faster.
+The above chart shows the performance of an echo server with different
+message sizes. The *sockets* benchmark uses ``loop.sock_recv()`` and
+``loop.sock_sendall()`` methods; the *streams* benchmark uses asyncio
+high-level streams, created by the ``asyncio.start_server()`` function;
+and the *protocol* benchmark uses ``loop.create_server()`` with a simple
+echo protocol. Read more about uvloop in a
+`blog post <http://magic.io/blog/uvloop-blazing-fast-python-networking/>`_
+about it.
+
+%prep
+%autosetup -n uvloop-0.17.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-uvloop -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.17.0-1
+- Package Spec generated