summaryrefslogtreecommitdiff
path: root/python-verchew.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-verchew.spec')
-rw-r--r--python-verchew.spec399
1 files changed, 399 insertions, 0 deletions
diff --git a/python-verchew.spec b/python-verchew.spec
new file mode 100644
index 0000000..f0f693f
--- /dev/null
+++ b/python-verchew.spec
@@ -0,0 +1,399 @@
+%global _empty_manifest_terminate_build 0
+Name: python-verchew
+Version: 3.3
+Release: 1
+Summary: System dependency version checker.
+License: MIT
+URL: https://pypi.org/project/verchew
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9c/91/a63bf158a2c627e05eebe9a6ec3e860297ab887cd94e2fd2adb55a90d779/verchew-3.3.tar.gz
+BuildArch: noarch
+
+
+%description
+# Overview
+
+> ...chews through your system dependencies, spitting out incompatible versions.
+
+When onboarding new team members, ensuring their computer has everything needed to work on the project can be painful. Verchew is a command-line program and embeddable Python script to check the versions of your project's system dependencies. Its only external dependency is any Python interpreter, which should already be installed on macOS and most Linux-based operating systems.
+
+[![Unix Build Status](https://img.shields.io/travis/jacebrowning/verchew/main.svg?label=unix)](https://travis-ci.org/jacebrowning/verchew)
+[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/verchew/main.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/verchew)
+[![Coverage Status](https://img.shields.io/coveralls/jacebrowning/verchew/main.svg)](https://coveralls.io/r/jacebrowning/verchew)
+[![Scrutinizer Code Quality](https://img.shields.io/scrutinizer/g/jacebrowning/verchew.svg)](https://scrutinizer-ci.com/g/jacebrowning/verchew/?branch=main)
+[![PyPI License](https://img.shields.io/pypi/l/verchew.svg)](https://pypi.org/project/verchew)
+[![PyPI Version](https://img.shields.io/pypi/v/verchew.svg)](https://pypi.python.org/pypi/verchew)
+[![PyPI Downloads](https://img.shields.io/pypi/dm/verchew.svg?color=orange)](https://pypistats.org/packages/verchew)
+
+# Setup
+
+## Requirements
+
+- Python 2.7+ or Python 3.3+
+
+## Installation
+
+Install `verchew` globally with [pipx](https://pipxproject.github.io/pipx/installation/) (or pip):
+
+```text
+$ pipx install verchew
+```
+
+or add it to your [Poetry](https://poetry.eustace.io/) project:
+
+```text
+$ poetry add verchew
+```
+
+or embedded the script in your project using [this guide](https://verchew.readthedocs.io/en/latest/cli/vendoring/).
+
+# Usage
+
+Run `verchew --init` to generate a sample configuration file.
+
+Update this file (`verchew.ini`) to include your project's system dependencies:
+
+```ini
+[Working Program]
+
+cli = working-program
+version = 1.2
+
+[Newer Working Program]
+
+cli = working-program
+version = 4.1 || 4.2
+message = Version 4.x is required to get the special features.
+
+[Broken Program]
+
+cli = broken-program
+version = 1.2.3
+
+[Optional Missing Program]
+
+cli = missing-program
+version = 1.2.3
+optional = true
+
+[Missing Program]
+
+cli = missing-program
+version = 1.2.3
+```
+
+Run `verchew` to see if you have the expected versions installed:
+
+```text
+$ verchew
+
+Checking for Working Program...
+
+$ working-program --version
+1.2.3
+✔ MATCHED: 1.2
+
+Checking for Newer Working Program...
+
+$ working-program --version
+1.2.3
+✘ EXPECTED: 4.1 || 4.2
+䷉ MESSAGE: Version 4.x is required to get the special features.
+
+Checking for Broken Program...
+
+$ broken-program --version
+An error occurred.
+✘ EXPECTED: 1.2.3
+
+Checking for Optional Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+▴ EXPECTED (OPTIONAL): 1.2.3
+
+Checking for Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+✘ EXPECTED: 1.2.3
+
+Results: ✔ ✘ ✘ ▴ ✘
+```
+
+
+%package -n python3-verchew
+Summary: System dependency version checker.
+Provides: python-verchew
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-verchew
+# Overview
+
+> ...chews through your system dependencies, spitting out incompatible versions.
+
+When onboarding new team members, ensuring their computer has everything needed to work on the project can be painful. Verchew is a command-line program and embeddable Python script to check the versions of your project's system dependencies. Its only external dependency is any Python interpreter, which should already be installed on macOS and most Linux-based operating systems.
+
+[![Unix Build Status](https://img.shields.io/travis/jacebrowning/verchew/main.svg?label=unix)](https://travis-ci.org/jacebrowning/verchew)
+[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/verchew/main.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/verchew)
+[![Coverage Status](https://img.shields.io/coveralls/jacebrowning/verchew/main.svg)](https://coveralls.io/r/jacebrowning/verchew)
+[![Scrutinizer Code Quality](https://img.shields.io/scrutinizer/g/jacebrowning/verchew.svg)](https://scrutinizer-ci.com/g/jacebrowning/verchew/?branch=main)
+[![PyPI License](https://img.shields.io/pypi/l/verchew.svg)](https://pypi.org/project/verchew)
+[![PyPI Version](https://img.shields.io/pypi/v/verchew.svg)](https://pypi.python.org/pypi/verchew)
+[![PyPI Downloads](https://img.shields.io/pypi/dm/verchew.svg?color=orange)](https://pypistats.org/packages/verchew)
+
+# Setup
+
+## Requirements
+
+- Python 2.7+ or Python 3.3+
+
+## Installation
+
+Install `verchew` globally with [pipx](https://pipxproject.github.io/pipx/installation/) (or pip):
+
+```text
+$ pipx install verchew
+```
+
+or add it to your [Poetry](https://poetry.eustace.io/) project:
+
+```text
+$ poetry add verchew
+```
+
+or embedded the script in your project using [this guide](https://verchew.readthedocs.io/en/latest/cli/vendoring/).
+
+# Usage
+
+Run `verchew --init` to generate a sample configuration file.
+
+Update this file (`verchew.ini`) to include your project's system dependencies:
+
+```ini
+[Working Program]
+
+cli = working-program
+version = 1.2
+
+[Newer Working Program]
+
+cli = working-program
+version = 4.1 || 4.2
+message = Version 4.x is required to get the special features.
+
+[Broken Program]
+
+cli = broken-program
+version = 1.2.3
+
+[Optional Missing Program]
+
+cli = missing-program
+version = 1.2.3
+optional = true
+
+[Missing Program]
+
+cli = missing-program
+version = 1.2.3
+```
+
+Run `verchew` to see if you have the expected versions installed:
+
+```text
+$ verchew
+
+Checking for Working Program...
+
+$ working-program --version
+1.2.3
+✔ MATCHED: 1.2
+
+Checking for Newer Working Program...
+
+$ working-program --version
+1.2.3
+✘ EXPECTED: 4.1 || 4.2
+䷉ MESSAGE: Version 4.x is required to get the special features.
+
+Checking for Broken Program...
+
+$ broken-program --version
+An error occurred.
+✘ EXPECTED: 1.2.3
+
+Checking for Optional Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+▴ EXPECTED (OPTIONAL): 1.2.3
+
+Checking for Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+✘ EXPECTED: 1.2.3
+
+Results: ✔ ✘ ✘ ▴ ✘
+```
+
+
+%package help
+Summary: Development documents and examples for verchew
+Provides: python3-verchew-doc
+%description help
+# Overview
+
+> ...chews through your system dependencies, spitting out incompatible versions.
+
+When onboarding new team members, ensuring their computer has everything needed to work on the project can be painful. Verchew is a command-line program and embeddable Python script to check the versions of your project's system dependencies. Its only external dependency is any Python interpreter, which should already be installed on macOS and most Linux-based operating systems.
+
+[![Unix Build Status](https://img.shields.io/travis/jacebrowning/verchew/main.svg?label=unix)](https://travis-ci.org/jacebrowning/verchew)
+[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/verchew/main.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/verchew)
+[![Coverage Status](https://img.shields.io/coveralls/jacebrowning/verchew/main.svg)](https://coveralls.io/r/jacebrowning/verchew)
+[![Scrutinizer Code Quality](https://img.shields.io/scrutinizer/g/jacebrowning/verchew.svg)](https://scrutinizer-ci.com/g/jacebrowning/verchew/?branch=main)
+[![PyPI License](https://img.shields.io/pypi/l/verchew.svg)](https://pypi.org/project/verchew)
+[![PyPI Version](https://img.shields.io/pypi/v/verchew.svg)](https://pypi.python.org/pypi/verchew)
+[![PyPI Downloads](https://img.shields.io/pypi/dm/verchew.svg?color=orange)](https://pypistats.org/packages/verchew)
+
+# Setup
+
+## Requirements
+
+- Python 2.7+ or Python 3.3+
+
+## Installation
+
+Install `verchew` globally with [pipx](https://pipxproject.github.io/pipx/installation/) (or pip):
+
+```text
+$ pipx install verchew
+```
+
+or add it to your [Poetry](https://poetry.eustace.io/) project:
+
+```text
+$ poetry add verchew
+```
+
+or embedded the script in your project using [this guide](https://verchew.readthedocs.io/en/latest/cli/vendoring/).
+
+# Usage
+
+Run `verchew --init` to generate a sample configuration file.
+
+Update this file (`verchew.ini`) to include your project's system dependencies:
+
+```ini
+[Working Program]
+
+cli = working-program
+version = 1.2
+
+[Newer Working Program]
+
+cli = working-program
+version = 4.1 || 4.2
+message = Version 4.x is required to get the special features.
+
+[Broken Program]
+
+cli = broken-program
+version = 1.2.3
+
+[Optional Missing Program]
+
+cli = missing-program
+version = 1.2.3
+optional = true
+
+[Missing Program]
+
+cli = missing-program
+version = 1.2.3
+```
+
+Run `verchew` to see if you have the expected versions installed:
+
+```text
+$ verchew
+
+Checking for Working Program...
+
+$ working-program --version
+1.2.3
+✔ MATCHED: 1.2
+
+Checking for Newer Working Program...
+
+$ working-program --version
+1.2.3
+✘ EXPECTED: 4.1 || 4.2
+䷉ MESSAGE: Version 4.x is required to get the special features.
+
+Checking for Broken Program...
+
+$ broken-program --version
+An error occurred.
+✘ EXPECTED: 1.2.3
+
+Checking for Optional Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+▴ EXPECTED (OPTIONAL): 1.2.3
+
+Checking for Missing Program...
+
+$ missing-program --version
+sh: command not found: missing-program
+✘ EXPECTED: 1.2.3
+
+Results: ✔ ✘ ✘ ▴ ✘
+```
+
+
+%prep
+%autosetup -n verchew-3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-verchew -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3-1
+- Package Spec generated