summaryrefslogtreecommitdiff
path: root/python-waltlabtools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-waltlabtools.spec')
-rw-r--r--python-waltlabtools.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-waltlabtools.spec b/python-waltlabtools.spec
new file mode 100644
index 0000000..a62a287
--- /dev/null
+++ b/python-waltlabtools.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-waltlabtools
+Version: 0.5.5
+Release: 1
+Summary: A collection of tools for biomedical research assay analysis in Python.
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/tylerdougan/waltlabtools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/79/f27270767b4fda5809276c002c306a4166675c9e071b2de172020a59f1f7/waltlabtools-0.5.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-matplotlib
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-scipy
+Requires: python3-scikit-learn
+Requires: python3-jax
+Requires: python3-numba
+
+%description
+A collection of tools for biomedical research assay analysis in Python.
+
+%package -n python3-waltlabtools
+Summary: A collection of tools for biomedical research assay analysis in Python.
+Provides: python-waltlabtools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-waltlabtools
+A collection of tools for biomedical research assay analysis in Python.
+
+%package help
+Summary: Development documents and examples for waltlabtools
+Provides: python3-waltlabtools-doc
+%description help
+A collection of tools for biomedical research assay analysis in Python.
+
+%prep
+%autosetup -n waltlabtools-0.5.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-waltlabtools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.5-1
+- Package Spec generated