summaryrefslogtreecommitdiff
path: root/python-webviz-subsurface.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-webviz-subsurface.spec')
-rw-r--r--python-webviz-subsurface.spec344
1 files changed, 344 insertions, 0 deletions
diff --git a/python-webviz-subsurface.spec b/python-webviz-subsurface.spec
new file mode 100644
index 0000000..0dd1527
--- /dev/null
+++ b/python-webviz-subsurface.spec
@@ -0,0 +1,344 @@
+%global _empty_manifest_terminate_build 0
+Name: python-webviz-subsurface
+Version: 0.2.19
+Release: 1
+Summary: Webviz config plugins for subsurface data
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/equinor/webviz-subsurface
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3b/57/80975071a275f4bee153fe034a35627ed01cd2b92a0c8555944b8d5316f2/webviz-subsurface-0.2.19.tar.gz
+BuildArch: noarch
+
+Requires: python3-dash
+Requires: python3-dash-bootstrap-components
+Requires: python3-dash-daq
+Requires: python3-defusedxml
+Requires: python3-flask-caching
+Requires: python3-fmu-ensemble
+Requires: python3-fmu-tools
+Requires: python3-geojson
+Requires: python3-jsonschema
+Requires: python3-pandas
+Requires: python3-pillow
+Requires: python3-pyarrow
+Requires: python3-pyjwt
+Requires: python3-pyscal
+Requires: python3-scipy
+Requires: python3-statsmodels
+Requires: python3-xtgeo
+Requires: python3-vtk
+Requires: python3-webviz-config
+Requires: python3-webviz-core-components
+Requires: python3-webviz-subsurface-components
+Requires: python3-ecl2df
+Requires: python3-opm
+Requires: python3-bandit
+Requires: python3-black
+Requires: python3-dash[testing]
+Requires: python3-flaky
+Requires: python3-isort
+Requires: python3-mypy
+Requires: python3-pylint
+Requires: python3-pytest-mock
+Requires: python3-pytest-xdist
+Requires: python3-selenium
+Requires: python3-types-pkg-resources
+Requires: python3-types-pyyaml
+
+%description
+[![PyPI version](https://badge.fury.io/py/webviz-subsurface.svg)](https://badge.fury.io/py/webviz-subsurface)
+[![Build Status](https://github.com/equinor/webviz-subsurface/workflows/webviz-subsurface/badge.svg)](https://github.com/equinor/webviz-subsurface/actions?query=branch%3Amaster)
+[![Total alerts](https://img.shields.io/lgtm/alerts/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/alerts/)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/context:python)
+[![Python 3.8 | 3.9 | 3.10](https://img.shields.io/badge/python-3.8%20|%203.9%20|%203.10-blue.svg)](https://www.python.org/)
+![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)
+
+## Webviz subsurface
+
+> :sparkles::eyeglasses: **[Live demo application](https://webviz-subsurface-example.azurewebsites.net)**
+
+### Introduction
+
+This repository contains subsurface specific standard `webviz` containers, which are used as
+plugins in [webviz-config](https://github.com/equinor/webviz-config).
+
+### Installation
+
+The easiest way of installing this package is to run
+```bash
+pip install webviz-subsurface
+```
+Add `--upgrade` if you have installed earlier, but want to upgrade to a newer version.
+
+If you want to install the latest, unreleased, code you can instead run
+```bash
+pip install git+https://github.com/equinor/webviz-subsurface
+```
+
+### Usage and documentation
+
+For general usage, see the documentation on
+[webviz-config](https://github.com/equinor/webviz-config). End-user documentation for
+the subsurface containers are automatically built and hosted on the
+[github pages](https://equinor.github.io/webviz-subsurface/) for this repository.
+
+There is also a [live demo application](https://webviz-subsurface-example.azurewebsites.net)
+showing how a created application can look like, using the `master` branch of this repository.
+
+### Example webviz configuration files
+
+Example `webviz` configuration files, and corresponding test data, is available at
+https://github.com/equinor/webviz-subsurface-testdata.
+
+See that repository for instructions on how to download and run the examples.
+
+### Creating new elements
+
+If you are interested in creating new elements which can be configured through
+the configuration file, take a look at the
+[webviz-config contribution guide](https://github.com/equinor/webviz-config/blob/master/CONTRIBUTING.md).
+
+You can do automatic linting of your code changes by running
+```bash
+black --check webviz_subsurface tests # Check code style
+pylint webviz_subsurface tests # Check code quality
+bandit -r -c ./bandit.yml webviz_subsurface tests # Check Python security best practice
+```
+
+### Review of contributions
+
+When doing review of contributions, it is usually useful to also see the resulting application live, and
+not only the code changes. In order to facilitate this, this repository is using GitHub actions.
+
+When on a feature branch, and a commit message including the substring `[deploy test]` arrives, the GitHub
+action workflow will try to build and deploy a test Docker image for you (which you then can link to a web app with
+e.g. automatic reload on new images). All you need to do in your own fork is to add
+GitHub secrets with the following names:
+ - `review_docker_registry_url`: The registry to push to (e.g. `myregistry.azurecr.io`)
+ - `review_docker_registry_username`: Registry login username.
+ - `review_docker_registry_token`: Registry login token (or password).
+ - `review_container_name`: What you want to call the container pushed to the registry.
+
+You are encouraged to rebase and squash/fixup unnecessary commits before pull request is merged to `master`.
+
+### Disclaimer
+
+This is a tool under heavy development. The current configuration file layout,
+also for subsurface containers, will therefore see large changes.
+
+
+%package -n python3-webviz-subsurface
+Summary: Webviz config plugins for subsurface data
+Provides: python-webviz-subsurface
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-webviz-subsurface
+[![PyPI version](https://badge.fury.io/py/webviz-subsurface.svg)](https://badge.fury.io/py/webviz-subsurface)
+[![Build Status](https://github.com/equinor/webviz-subsurface/workflows/webviz-subsurface/badge.svg)](https://github.com/equinor/webviz-subsurface/actions?query=branch%3Amaster)
+[![Total alerts](https://img.shields.io/lgtm/alerts/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/alerts/)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/context:python)
+[![Python 3.8 | 3.9 | 3.10](https://img.shields.io/badge/python-3.8%20|%203.9%20|%203.10-blue.svg)](https://www.python.org/)
+![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)
+
+## Webviz subsurface
+
+> :sparkles::eyeglasses: **[Live demo application](https://webviz-subsurface-example.azurewebsites.net)**
+
+### Introduction
+
+This repository contains subsurface specific standard `webviz` containers, which are used as
+plugins in [webviz-config](https://github.com/equinor/webviz-config).
+
+### Installation
+
+The easiest way of installing this package is to run
+```bash
+pip install webviz-subsurface
+```
+Add `--upgrade` if you have installed earlier, but want to upgrade to a newer version.
+
+If you want to install the latest, unreleased, code you can instead run
+```bash
+pip install git+https://github.com/equinor/webviz-subsurface
+```
+
+### Usage and documentation
+
+For general usage, see the documentation on
+[webviz-config](https://github.com/equinor/webviz-config). End-user documentation for
+the subsurface containers are automatically built and hosted on the
+[github pages](https://equinor.github.io/webviz-subsurface/) for this repository.
+
+There is also a [live demo application](https://webviz-subsurface-example.azurewebsites.net)
+showing how a created application can look like, using the `master` branch of this repository.
+
+### Example webviz configuration files
+
+Example `webviz` configuration files, and corresponding test data, is available at
+https://github.com/equinor/webviz-subsurface-testdata.
+
+See that repository for instructions on how to download and run the examples.
+
+### Creating new elements
+
+If you are interested in creating new elements which can be configured through
+the configuration file, take a look at the
+[webviz-config contribution guide](https://github.com/equinor/webviz-config/blob/master/CONTRIBUTING.md).
+
+You can do automatic linting of your code changes by running
+```bash
+black --check webviz_subsurface tests # Check code style
+pylint webviz_subsurface tests # Check code quality
+bandit -r -c ./bandit.yml webviz_subsurface tests # Check Python security best practice
+```
+
+### Review of contributions
+
+When doing review of contributions, it is usually useful to also see the resulting application live, and
+not only the code changes. In order to facilitate this, this repository is using GitHub actions.
+
+When on a feature branch, and a commit message including the substring `[deploy test]` arrives, the GitHub
+action workflow will try to build and deploy a test Docker image for you (which you then can link to a web app with
+e.g. automatic reload on new images). All you need to do in your own fork is to add
+GitHub secrets with the following names:
+ - `review_docker_registry_url`: The registry to push to (e.g. `myregistry.azurecr.io`)
+ - `review_docker_registry_username`: Registry login username.
+ - `review_docker_registry_token`: Registry login token (or password).
+ - `review_container_name`: What you want to call the container pushed to the registry.
+
+You are encouraged to rebase and squash/fixup unnecessary commits before pull request is merged to `master`.
+
+### Disclaimer
+
+This is a tool under heavy development. The current configuration file layout,
+also for subsurface containers, will therefore see large changes.
+
+
+%package help
+Summary: Development documents and examples for webviz-subsurface
+Provides: python3-webviz-subsurface-doc
+%description help
+[![PyPI version](https://badge.fury.io/py/webviz-subsurface.svg)](https://badge.fury.io/py/webviz-subsurface)
+[![Build Status](https://github.com/equinor/webviz-subsurface/workflows/webviz-subsurface/badge.svg)](https://github.com/equinor/webviz-subsurface/actions?query=branch%3Amaster)
+[![Total alerts](https://img.shields.io/lgtm/alerts/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/alerts/)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/equinor/webviz-subsurface.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/equinor/webviz-subsurface/context:python)
+[![Python 3.8 | 3.9 | 3.10](https://img.shields.io/badge/python-3.8%20|%203.9%20|%203.10-blue.svg)](https://www.python.org/)
+![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)
+
+## Webviz subsurface
+
+> :sparkles::eyeglasses: **[Live demo application](https://webviz-subsurface-example.azurewebsites.net)**
+
+### Introduction
+
+This repository contains subsurface specific standard `webviz` containers, which are used as
+plugins in [webviz-config](https://github.com/equinor/webviz-config).
+
+### Installation
+
+The easiest way of installing this package is to run
+```bash
+pip install webviz-subsurface
+```
+Add `--upgrade` if you have installed earlier, but want to upgrade to a newer version.
+
+If you want to install the latest, unreleased, code you can instead run
+```bash
+pip install git+https://github.com/equinor/webviz-subsurface
+```
+
+### Usage and documentation
+
+For general usage, see the documentation on
+[webviz-config](https://github.com/equinor/webviz-config). End-user documentation for
+the subsurface containers are automatically built and hosted on the
+[github pages](https://equinor.github.io/webviz-subsurface/) for this repository.
+
+There is also a [live demo application](https://webviz-subsurface-example.azurewebsites.net)
+showing how a created application can look like, using the `master` branch of this repository.
+
+### Example webviz configuration files
+
+Example `webviz` configuration files, and corresponding test data, is available at
+https://github.com/equinor/webviz-subsurface-testdata.
+
+See that repository for instructions on how to download and run the examples.
+
+### Creating new elements
+
+If you are interested in creating new elements which can be configured through
+the configuration file, take a look at the
+[webviz-config contribution guide](https://github.com/equinor/webviz-config/blob/master/CONTRIBUTING.md).
+
+You can do automatic linting of your code changes by running
+```bash
+black --check webviz_subsurface tests # Check code style
+pylint webviz_subsurface tests # Check code quality
+bandit -r -c ./bandit.yml webviz_subsurface tests # Check Python security best practice
+```
+
+### Review of contributions
+
+When doing review of contributions, it is usually useful to also see the resulting application live, and
+not only the code changes. In order to facilitate this, this repository is using GitHub actions.
+
+When on a feature branch, and a commit message including the substring `[deploy test]` arrives, the GitHub
+action workflow will try to build and deploy a test Docker image for you (which you then can link to a web app with
+e.g. automatic reload on new images). All you need to do in your own fork is to add
+GitHub secrets with the following names:
+ - `review_docker_registry_url`: The registry to push to (e.g. `myregistry.azurecr.io`)
+ - `review_docker_registry_username`: Registry login username.
+ - `review_docker_registry_token`: Registry login token (or password).
+ - `review_container_name`: What you want to call the container pushed to the registry.
+
+You are encouraged to rebase and squash/fixup unnecessary commits before pull request is merged to `master`.
+
+### Disclaimer
+
+This is a tool under heavy development. The current configuration file layout,
+also for subsurface containers, will therefore see large changes.
+
+
+%prep
+%autosetup -n webviz-subsurface-0.2.19
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-webviz-subsurface -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.19-1
+- Package Spec generated