summaryrefslogtreecommitdiff
path: root/python-wikitextparser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-wikitextparser.spec')
-rw-r--r--python-wikitextparser.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-wikitextparser.spec b/python-wikitextparser.spec
new file mode 100644
index 0000000..852a43e
--- /dev/null
+++ b/python-wikitextparser.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-wikitextparser
+Version: 0.51.2
+Release: 1
+Summary: A simple parsing tool for MediaWiki's wikitext markup.
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/5j9/wikitextparser
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a7/bc/c3f42ac1d97345d3bac15417d574bccca337632f72748ebb98210ca3a1b6/wikitextparser-0.51.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-regex
+Requires: python3-wcwidth
+Requires: python3-path
+Requires: python3-coverage
+Requires: python3-twine
+Requires: python3-pytest
+
+%description
+
+
+%package -n python3-wikitextparser
+Summary: A simple parsing tool for MediaWiki's wikitext markup.
+Provides: python-wikitextparser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-wikitextparser
+
+
+%package help
+Summary: Development documents and examples for wikitextparser
+Provides: python3-wikitextparser-doc
+%description help
+
+
+%prep
+%autosetup -n wikitextparser-0.51.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-wikitextparser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.51.2-1
+- Package Spec generated