summaryrefslogtreecommitdiff
path: root/python-word2vec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-word2vec.spec')
-rw-r--r--python-word2vec.spec201
1 files changed, 201 insertions, 0 deletions
diff --git a/python-word2vec.spec b/python-word2vec.spec
new file mode 100644
index 0000000..33d14b5
--- /dev/null
+++ b/python-word2vec.spec
@@ -0,0 +1,201 @@
+%global _empty_manifest_terminate_build 0
+Name: python-word2vec
+Version: 0.11.1
+Release: 1
+Summary: Wrapper for Google word2vec
+License: Apache License, Version 2.0
+URL: https://github.com/danielfrg/word2vec
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/11/9e/dc6d96578191b6167cb1ea4a3fe3edeed0dce54d3db21ada013b2b407d65/word2vec-0.11.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# word2vec
+
+[![PyPI](https://badge.fury.io/py/word2vec.svg)](https://pypi.org/project/word2vec/)
+[![Testing](http://github.com/danielfrg/word2vec/workflows/test/badge.svg)](http://github.com/danielfrg/word2vec/actions)
+[![Coverage Status](https://codecov.io/gh/danielfrg/word2vec/branch/master/graph/badge.svg)](https://codecov.io/gh/danielfrg/word2vec?branch=master)
+[![License](http://img.shields.io/:license-Apache%202-blue.svg)](http://github.com/danielfrg/word2vec/blob/master/LICENSE.txt)
+
+Python interface to Google word2vec.
+
+Training is done using the original C code, other functionality is pure Python with numpy.
+
+## Installation
+
+```
+pip install word2vec
+```
+
+The installation requires to compile the original C code:
+
+### Compilation
+
+In order to compile the original C code a `gcc` compiler is needed.
+
+You can override the compilation flags if needed:
+
+```
+WORD2VEC_CFLAGS='-march=corei7' pip install word2vec
+```
+
+**Windows:** There is basic some support for this support based on this [win32 port](https://github.com/zhangyafeikimi/word2vec-win32).
+
+## Usage
+
+Example notebook: [word2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/word2vec.ipynb)
+
+The default functionality from word2vec is available from the command line:
+- `word2vec`
+- `word2phrase`
+- `word2vec-distance`
+- `word2vec-word-analogy`
+- `word2vec-compute-accuracy`
+
+Experimental functionality on doc2vec can be found in this other example:
+[doc2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/doc2vec.ipynb)
+
+%package -n python3-word2vec
+Summary: Wrapper for Google word2vec
+Provides: python-word2vec
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-word2vec
+# word2vec
+
+[![PyPI](https://badge.fury.io/py/word2vec.svg)](https://pypi.org/project/word2vec/)
+[![Testing](http://github.com/danielfrg/word2vec/workflows/test/badge.svg)](http://github.com/danielfrg/word2vec/actions)
+[![Coverage Status](https://codecov.io/gh/danielfrg/word2vec/branch/master/graph/badge.svg)](https://codecov.io/gh/danielfrg/word2vec?branch=master)
+[![License](http://img.shields.io/:license-Apache%202-blue.svg)](http://github.com/danielfrg/word2vec/blob/master/LICENSE.txt)
+
+Python interface to Google word2vec.
+
+Training is done using the original C code, other functionality is pure Python with numpy.
+
+## Installation
+
+```
+pip install word2vec
+```
+
+The installation requires to compile the original C code:
+
+### Compilation
+
+In order to compile the original C code a `gcc` compiler is needed.
+
+You can override the compilation flags if needed:
+
+```
+WORD2VEC_CFLAGS='-march=corei7' pip install word2vec
+```
+
+**Windows:** There is basic some support for this support based on this [win32 port](https://github.com/zhangyafeikimi/word2vec-win32).
+
+## Usage
+
+Example notebook: [word2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/word2vec.ipynb)
+
+The default functionality from word2vec is available from the command line:
+- `word2vec`
+- `word2phrase`
+- `word2vec-distance`
+- `word2vec-word-analogy`
+- `word2vec-compute-accuracy`
+
+Experimental functionality on doc2vec can be found in this other example:
+[doc2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/doc2vec.ipynb)
+
+%package help
+Summary: Development documents and examples for word2vec
+Provides: python3-word2vec-doc
+%description help
+# word2vec
+
+[![PyPI](https://badge.fury.io/py/word2vec.svg)](https://pypi.org/project/word2vec/)
+[![Testing](http://github.com/danielfrg/word2vec/workflows/test/badge.svg)](http://github.com/danielfrg/word2vec/actions)
+[![Coverage Status](https://codecov.io/gh/danielfrg/word2vec/branch/master/graph/badge.svg)](https://codecov.io/gh/danielfrg/word2vec?branch=master)
+[![License](http://img.shields.io/:license-Apache%202-blue.svg)](http://github.com/danielfrg/word2vec/blob/master/LICENSE.txt)
+
+Python interface to Google word2vec.
+
+Training is done using the original C code, other functionality is pure Python with numpy.
+
+## Installation
+
+```
+pip install word2vec
+```
+
+The installation requires to compile the original C code:
+
+### Compilation
+
+In order to compile the original C code a `gcc` compiler is needed.
+
+You can override the compilation flags if needed:
+
+```
+WORD2VEC_CFLAGS='-march=corei7' pip install word2vec
+```
+
+**Windows:** There is basic some support for this support based on this [win32 port](https://github.com/zhangyafeikimi/word2vec-win32).
+
+## Usage
+
+Example notebook: [word2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/word2vec.ipynb)
+
+The default functionality from word2vec is available from the command line:
+- `word2vec`
+- `word2phrase`
+- `word2vec-distance`
+- `word2vec-word-analogy`
+- `word2vec-compute-accuracy`
+
+Experimental functionality on doc2vec can be found in this other example:
+[doc2vec](http://nbviewer.ipython.org/urls/raw.github.com/danielfrg/word2vec/master/examples/doc2vec.ipynb)
+
+%prep
+%autosetup -n word2vec-0.11.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-word2vec -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.1-1
+- Package Spec generated