summaryrefslogtreecommitdiff
path: root/python-xone.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-xone.spec')
-rw-r--r--python-xone.spec157
1 files changed, 157 insertions, 0 deletions
diff --git a/python-xone.spec b/python-xone.spec
new file mode 100644
index 0000000..5ef46ee
--- /dev/null
+++ b/python-xone.spec
@@ -0,0 +1,157 @@
+%global _empty_manifest_terminate_build 0
+Name: python-xone
+Version: 0.1.7
+Release: 1
+Summary: Frequently used functions for financial data analysis
+License: Apache
+URL: https://github.com/alpha-xone/xone
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c6/8e/b8538a3b680fc745ad241a689d7b01814d7965335d86e74c2ee3bc83dc0a/xone-0.1.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-matplotlib
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-pyarrow
+Requires: python3-pytz
+Requires: python3-parse
+Requires: python3-tqdm
+Requires: python3-beautifulsoup4
+Requires: python3-selenium
+Requires: python3-requests
+
+%description
+# x1
+
+[![PyPI version](https://img.shields.io/pypi/v/xone.svg)](https://badge.fury.io/py/xone)
+[![PyPI version](https://img.shields.io/pypi/pyversions/xone.svg)](https://badge.fury.io/py/xone)
+
+[![Coffee](https://www.buymeacoffee.com/assets/img/custom_images/purple_img.png)](https://www.buymeacoffee.com/Lntx29Oof)
+
+Frequently used functions for financial data analysis
+
+## Installation
+
+```cmd
+pip install xone
+```
+
+| | |
+| -------------- | ----------------------------------------------------------------------------------------------------------------------------------------------- |
+| Docs | [![Documentation Status](https://readthedocs.org/projects/xone/badge/?version=latest)](https://xone.readthedocs.io/en/latest) |
+| Build | [![Actions Status](https://github.com/alpha-xone/xone/workflows/Auto%20CI/badge.svg)](https://github.com/alpha-xone/xone/actions) |
+| Coverage | [![codecov](https://codecov.io/gh/alpha-xone/xone/branch/master/graph/badge.svg)](https://codecov.io/gh/alpha-xone/xone) |
+| Quality | [![Codacy Badge](https://api.codacy.com/project/badge/Grade/eb3d11949a1343d9aa4806a31f3fcc41)](https://www.codacy.com/app/alpha-xone/xone) |
+| | [![CodeFactor](https://www.codefactor.io/repository/github/alpha-xone/xone/badge)](https://www.codefactor.io/repository/github/alpha-xone/xone) |
+| License | [![GitHub license](https://img.shields.io/github/license/alpha-xone/xone.svg)](https://github.com/alpha-xone/xone/blob/master/LICENSE) |
+
+
+
+
+%package -n python3-xone
+Summary: Frequently used functions for financial data analysis
+Provides: python-xone
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-xone
+# x1
+
+[![PyPI version](https://img.shields.io/pypi/v/xone.svg)](https://badge.fury.io/py/xone)
+[![PyPI version](https://img.shields.io/pypi/pyversions/xone.svg)](https://badge.fury.io/py/xone)
+
+[![Coffee](https://www.buymeacoffee.com/assets/img/custom_images/purple_img.png)](https://www.buymeacoffee.com/Lntx29Oof)
+
+Frequently used functions for financial data analysis
+
+## Installation
+
+```cmd
+pip install xone
+```
+
+| | |
+| -------------- | ----------------------------------------------------------------------------------------------------------------------------------------------- |
+| Docs | [![Documentation Status](https://readthedocs.org/projects/xone/badge/?version=latest)](https://xone.readthedocs.io/en/latest) |
+| Build | [![Actions Status](https://github.com/alpha-xone/xone/workflows/Auto%20CI/badge.svg)](https://github.com/alpha-xone/xone/actions) |
+| Coverage | [![codecov](https://codecov.io/gh/alpha-xone/xone/branch/master/graph/badge.svg)](https://codecov.io/gh/alpha-xone/xone) |
+| Quality | [![Codacy Badge](https://api.codacy.com/project/badge/Grade/eb3d11949a1343d9aa4806a31f3fcc41)](https://www.codacy.com/app/alpha-xone/xone) |
+| | [![CodeFactor](https://www.codefactor.io/repository/github/alpha-xone/xone/badge)](https://www.codefactor.io/repository/github/alpha-xone/xone) |
+| License | [![GitHub license](https://img.shields.io/github/license/alpha-xone/xone.svg)](https://github.com/alpha-xone/xone/blob/master/LICENSE) |
+
+
+
+
+%package help
+Summary: Development documents and examples for xone
+Provides: python3-xone-doc
+%description help
+# x1
+
+[![PyPI version](https://img.shields.io/pypi/v/xone.svg)](https://badge.fury.io/py/xone)
+[![PyPI version](https://img.shields.io/pypi/pyversions/xone.svg)](https://badge.fury.io/py/xone)
+
+[![Coffee](https://www.buymeacoffee.com/assets/img/custom_images/purple_img.png)](https://www.buymeacoffee.com/Lntx29Oof)
+
+Frequently used functions for financial data analysis
+
+## Installation
+
+```cmd
+pip install xone
+```
+
+| | |
+| -------------- | ----------------------------------------------------------------------------------------------------------------------------------------------- |
+| Docs | [![Documentation Status](https://readthedocs.org/projects/xone/badge/?version=latest)](https://xone.readthedocs.io/en/latest) |
+| Build | [![Actions Status](https://github.com/alpha-xone/xone/workflows/Auto%20CI/badge.svg)](https://github.com/alpha-xone/xone/actions) |
+| Coverage | [![codecov](https://codecov.io/gh/alpha-xone/xone/branch/master/graph/badge.svg)](https://codecov.io/gh/alpha-xone/xone) |
+| Quality | [![Codacy Badge](https://api.codacy.com/project/badge/Grade/eb3d11949a1343d9aa4806a31f3fcc41)](https://www.codacy.com/app/alpha-xone/xone) |
+| | [![CodeFactor](https://www.codefactor.io/repository/github/alpha-xone/xone/badge)](https://www.codefactor.io/repository/github/alpha-xone/xone) |
+| License | [![GitHub license](https://img.shields.io/github/license/alpha-xone/xone.svg)](https://github.com/alpha-xone/xone/blob/master/LICENSE) |
+
+
+
+
+%prep
+%autosetup -n xone-0.1.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-xone -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.7-1
+- Package Spec generated