summaryrefslogtreecommitdiff
path: root/python-yea-wandb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-yea-wandb.spec')
-rw-r--r--python-yea-wandb.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/python-yea-wandb.spec b/python-yea-wandb.spec
new file mode 100644
index 0000000..8861780
--- /dev/null
+++ b/python-yea-wandb.spec
@@ -0,0 +1,77 @@
+%global _empty_manifest_terminate_build 0
+Name: python-yea-wandb
+Version: 0.9.7
+Release: 1
+Summary: Test harness wandb plugin
+License: MIT license
+URL: https://pypi.org/project/yea-wandb/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/37/f4/b0a5374f8eb36689153c57d4e67e802e9c3bbc8e3d9b7ec301836b740442/yea-wandb-0.9.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-Flask
+Requires: python3-requests
+Requires: python3-responses
+Requires: python3-pandas
+Requires: python3-yea
+
+%description
+
+
+%package -n python3-yea-wandb
+Summary: Test harness wandb plugin
+Provides: python-yea-wandb
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-yea-wandb
+
+
+%package help
+Summary: Development documents and examples for yea-wandb
+Provides: python3-yea-wandb-doc
+%description help
+
+
+%prep
+%autosetup -n yea-wandb-0.9.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-yea-wandb -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.7-1
+- Package Spec generated