summaryrefslogtreecommitdiff
path: root/python-ypricemagic.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ypricemagic.spec')
-rw-r--r--python-ypricemagic.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-ypricemagic.spec b/python-ypricemagic.spec
new file mode 100644
index 0000000..9202d9f
--- /dev/null
+++ b/python-ypricemagic.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ypricemagic
+Version: 2.1.1
+Release: 1
+Summary: Use this tool to extract historical on-chain price data from an archive node. Shoutout to @bantg and @nymmrx for their awesome work on yearn-exporter that made this library possible.
+License: MIT
+URL: https://github.com/BobTheBuidler/ypricemagic
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e4/b7/c73a8e1a9c1a9fb2c02d84edd8e49e42972977f45af7089b8e0aead956f5/ypricemagic-2.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-bobs-lazy-logging
+Requires: python3-cachetools
+Requires: python3-checksum-dict
+Requires: python3-dank-mids
+Requires: python3-eth-brownie
+Requires: python3-eth-retry
+Requires: python3-ez-a-sync
+Requires: python3-joblib
+
+%description
+
+
+%package -n python3-ypricemagic
+Summary: Use this tool to extract historical on-chain price data from an archive node. Shoutout to @bantg and @nymmrx for their awesome work on yearn-exporter that made this library possible.
+Provides: python-ypricemagic
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ypricemagic
+
+
+%package help
+Summary: Development documents and examples for ypricemagic
+Provides: python3-ypricemagic-doc
+%description help
+
+
+%prep
+%autosetup -n ypricemagic-2.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ypricemagic -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
+- Package Spec generated