summaryrefslogtreecommitdiff
path: root/python-zepid.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zepid.spec')
-rw-r--r--python-zepid.spec357
1 files changed, 357 insertions, 0 deletions
diff --git a/python-zepid.spec b/python-zepid.spec
new file mode 100644
index 0000000..085beea
--- /dev/null
+++ b/python-zepid.spec
@@ -0,0 +1,357 @@
+%global _empty_manifest_terminate_build 0
+Name: python-zepid
+Version: 0.9.1
+Release: 1
+Summary: Tool package for epidemiologic analyses
+License: MIT
+URL: https://github.com/pzivich/zepid
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2b/d8/a357673e807d3cc644f8a470a3c28d287788a128646b8fa7085e62f62f6c/zepid-0.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-statsmodels
+Requires: python3-matplotlib
+Requires: python3-scipy
+Requires: python3-tabulate
+Requires: python3-scikit-learn
+Requires: python3-patsy
+Requires: python3-networkx
+
+%description
+![zepid](docs/images/zepid_logo.png)
+# zEpid
+
+[![PyPI version](https://badge.fury.io/py/zepid.svg)](https://badge.fury.io/py/zepid)
+[![Python package](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml/badge.svg)](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml)
+[![Documentation Status](https://readthedocs.org/projects/zepid/badge/?version=latest)](https://zepid.readthedocs.io/en/latest/?badge=latest)
+[![Join the chat at https://gitter.im/zEpid/community](https://badges.gitter.im/zEpid/community.svg)](https://gitter.im/zEpid/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
+
+zEpid is an epidemiology analysis package, providing easy to use tools for epidemiologists coding in Python 3.5+. The
+purpose of this library is to provide a toolset to make epidemiology e-z. A variety of calculations and plots can be
+generated through various functions. For a sample walkthrough of what this library is capable of, please look at the
+tutorials available at https://github.com/pzivich/Python-for-Epidemiologists
+
+A few highlights: basic epidemiology calculations, easily create functional form assessment plots,
+easily create effect measure plots, and causal inference tools. Implemented estimators include; inverse
+probability of treatment weights, inverse probability of censoring weights, inverse probabilitiy of missing weights,
+augmented inverse probability of treatment weights, time-fixed g-formula, Monte Carlo g-formula, Iterative conditional
+g-formula, and targeted maximum likelihood (TMLE). Additionally, generalizability/transportability tools are available
+including; inverse probability of sampling weights, g-transport formula, and doubly robust
+generalizability/transportability formulas.
+
+If you have any requests for items to be included, please contact me and I will work on adding any requested features.
+You can contact me either through GitHub (https://github.com/pzivich), email (gmail: zepidpy), or twitter (@zepidpy).
+
+# Installation
+
+## Installing:
+You can install zEpid using `pip install zepid`
+
+## Dependencies:
+pandas >= 0.18.0, numpy, statsmodels >= 0.7.0, matplotlib >= 2.0, scipy, tabulate
+
+# Module Features
+
+## Measures
+Calculate measures directly from a pandas dataframe object. Implemented measures include; risk ratio, risk difference,
+odds ratio, incidence rate ratio, incidence rate difference, number needed to treat, sensitivity, specificity,
+population attributable fraction, attributable community risk
+
+Measures can be directly calculated from a pandas DataFrame object or using summary data.
+
+Other handy features include; splines, Table 1 generator, interaction contrast, interaction contrast ratio, positive
+predictive value, negative predictive value, screening cost analyzer, counternull p-values, convert odds to
+proportions, convert proportions to odds
+
+For guided tutorials with Jupyter Notebooks:
+https://github.com/pzivich/Python-for-Epidemiologists/blob/master/3_Epidemiology_Analysis/a_basics/1_basic_measures.ipynb
+
+## Graphics
+Uses matplotlib in the background to generate some useful plots. Implemented plots include; functional form assessment
+(with statsmodels output), p-value function plots, spaghetti plot, effect measure plot (forest plot), receiver-operator
+curve, dynamic risk plots, and L'Abbe plots
+
+For examples see:
+http://zepid.readthedocs.io/en/latest/Graphics.html
+
+## Causal
+The causal branch includes various estimators for causal inference with observational data. Details on currently
+implemented estimators are below:
+
+### G-Computation Algorithm
+Current implementation includes; time-fixed exposure g-formula, Monte Carlo g-formula, and iterative conditional
+g-formula
+
+### Inverse Probability Weights
+Current implementation includes; IP Treatment W, IP Censoring W, IP Missing W. Diagnostics are also available for IPTW.
+IPMW supports monotone missing data
+
+### Augmented Inverse Probability Weights
+Current implementation includes the augmented-IPTW estimator described by Funk et al 2011 AJE
+
+### Targeted Maximum Likelihood Estimator
+TMLE can be estimated through standard logistic regression model, or through user-input functions. Alternatively, users
+can input machine learning algorithms to estimate probabilities. Supported machine learning algorithms include `sklearn`
+
+### Generalizability / Transportability
+For generalizing results or transporting to a different target population, several estimators are available. These
+include inverse probability of sampling weights, g-transport formula, and doubly robust formulas
+
+Tutorials for the usage of these estimators are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/c_causal_inference
+
+#### G-estimation of Structural Nested Mean Models
+Single time-point g-estimation of structural nested mean models are supported.
+
+## Sensitivity Analyses
+Includes trapezoidal distribution generator, corrected Risk Ratio
+
+Tutorials are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/d_sensitivity_analyses
+
+
+
+
+%package -n python3-zepid
+Summary: Tool package for epidemiologic analyses
+Provides: python-zepid
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-zepid
+![zepid](docs/images/zepid_logo.png)
+# zEpid
+
+[![PyPI version](https://badge.fury.io/py/zepid.svg)](https://badge.fury.io/py/zepid)
+[![Python package](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml/badge.svg)](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml)
+[![Documentation Status](https://readthedocs.org/projects/zepid/badge/?version=latest)](https://zepid.readthedocs.io/en/latest/?badge=latest)
+[![Join the chat at https://gitter.im/zEpid/community](https://badges.gitter.im/zEpid/community.svg)](https://gitter.im/zEpid/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
+
+zEpid is an epidemiology analysis package, providing easy to use tools for epidemiologists coding in Python 3.5+. The
+purpose of this library is to provide a toolset to make epidemiology e-z. A variety of calculations and plots can be
+generated through various functions. For a sample walkthrough of what this library is capable of, please look at the
+tutorials available at https://github.com/pzivich/Python-for-Epidemiologists
+
+A few highlights: basic epidemiology calculations, easily create functional form assessment plots,
+easily create effect measure plots, and causal inference tools. Implemented estimators include; inverse
+probability of treatment weights, inverse probability of censoring weights, inverse probabilitiy of missing weights,
+augmented inverse probability of treatment weights, time-fixed g-formula, Monte Carlo g-formula, Iterative conditional
+g-formula, and targeted maximum likelihood (TMLE). Additionally, generalizability/transportability tools are available
+including; inverse probability of sampling weights, g-transport formula, and doubly robust
+generalizability/transportability formulas.
+
+If you have any requests for items to be included, please contact me and I will work on adding any requested features.
+You can contact me either through GitHub (https://github.com/pzivich), email (gmail: zepidpy), or twitter (@zepidpy).
+
+# Installation
+
+## Installing:
+You can install zEpid using `pip install zepid`
+
+## Dependencies:
+pandas >= 0.18.0, numpy, statsmodels >= 0.7.0, matplotlib >= 2.0, scipy, tabulate
+
+# Module Features
+
+## Measures
+Calculate measures directly from a pandas dataframe object. Implemented measures include; risk ratio, risk difference,
+odds ratio, incidence rate ratio, incidence rate difference, number needed to treat, sensitivity, specificity,
+population attributable fraction, attributable community risk
+
+Measures can be directly calculated from a pandas DataFrame object or using summary data.
+
+Other handy features include; splines, Table 1 generator, interaction contrast, interaction contrast ratio, positive
+predictive value, negative predictive value, screening cost analyzer, counternull p-values, convert odds to
+proportions, convert proportions to odds
+
+For guided tutorials with Jupyter Notebooks:
+https://github.com/pzivich/Python-for-Epidemiologists/blob/master/3_Epidemiology_Analysis/a_basics/1_basic_measures.ipynb
+
+## Graphics
+Uses matplotlib in the background to generate some useful plots. Implemented plots include; functional form assessment
+(with statsmodels output), p-value function plots, spaghetti plot, effect measure plot (forest plot), receiver-operator
+curve, dynamic risk plots, and L'Abbe plots
+
+For examples see:
+http://zepid.readthedocs.io/en/latest/Graphics.html
+
+## Causal
+The causal branch includes various estimators for causal inference with observational data. Details on currently
+implemented estimators are below:
+
+### G-Computation Algorithm
+Current implementation includes; time-fixed exposure g-formula, Monte Carlo g-formula, and iterative conditional
+g-formula
+
+### Inverse Probability Weights
+Current implementation includes; IP Treatment W, IP Censoring W, IP Missing W. Diagnostics are also available for IPTW.
+IPMW supports monotone missing data
+
+### Augmented Inverse Probability Weights
+Current implementation includes the augmented-IPTW estimator described by Funk et al 2011 AJE
+
+### Targeted Maximum Likelihood Estimator
+TMLE can be estimated through standard logistic regression model, or through user-input functions. Alternatively, users
+can input machine learning algorithms to estimate probabilities. Supported machine learning algorithms include `sklearn`
+
+### Generalizability / Transportability
+For generalizing results or transporting to a different target population, several estimators are available. These
+include inverse probability of sampling weights, g-transport formula, and doubly robust formulas
+
+Tutorials for the usage of these estimators are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/c_causal_inference
+
+#### G-estimation of Structural Nested Mean Models
+Single time-point g-estimation of structural nested mean models are supported.
+
+## Sensitivity Analyses
+Includes trapezoidal distribution generator, corrected Risk Ratio
+
+Tutorials are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/d_sensitivity_analyses
+
+
+
+
+%package help
+Summary: Development documents and examples for zepid
+Provides: python3-zepid-doc
+%description help
+![zepid](docs/images/zepid_logo.png)
+# zEpid
+
+[![PyPI version](https://badge.fury.io/py/zepid.svg)](https://badge.fury.io/py/zepid)
+[![Python package](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml/badge.svg)](https://github.com/pzivich/zEpid/actions/workflows/python-package.yml)
+[![Documentation Status](https://readthedocs.org/projects/zepid/badge/?version=latest)](https://zepid.readthedocs.io/en/latest/?badge=latest)
+[![Join the chat at https://gitter.im/zEpid/community](https://badges.gitter.im/zEpid/community.svg)](https://gitter.im/zEpid/community?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
+
+zEpid is an epidemiology analysis package, providing easy to use tools for epidemiologists coding in Python 3.5+. The
+purpose of this library is to provide a toolset to make epidemiology e-z. A variety of calculations and plots can be
+generated through various functions. For a sample walkthrough of what this library is capable of, please look at the
+tutorials available at https://github.com/pzivich/Python-for-Epidemiologists
+
+A few highlights: basic epidemiology calculations, easily create functional form assessment plots,
+easily create effect measure plots, and causal inference tools. Implemented estimators include; inverse
+probability of treatment weights, inverse probability of censoring weights, inverse probabilitiy of missing weights,
+augmented inverse probability of treatment weights, time-fixed g-formula, Monte Carlo g-formula, Iterative conditional
+g-formula, and targeted maximum likelihood (TMLE). Additionally, generalizability/transportability tools are available
+including; inverse probability of sampling weights, g-transport formula, and doubly robust
+generalizability/transportability formulas.
+
+If you have any requests for items to be included, please contact me and I will work on adding any requested features.
+You can contact me either through GitHub (https://github.com/pzivich), email (gmail: zepidpy), or twitter (@zepidpy).
+
+# Installation
+
+## Installing:
+You can install zEpid using `pip install zepid`
+
+## Dependencies:
+pandas >= 0.18.0, numpy, statsmodels >= 0.7.0, matplotlib >= 2.0, scipy, tabulate
+
+# Module Features
+
+## Measures
+Calculate measures directly from a pandas dataframe object. Implemented measures include; risk ratio, risk difference,
+odds ratio, incidence rate ratio, incidence rate difference, number needed to treat, sensitivity, specificity,
+population attributable fraction, attributable community risk
+
+Measures can be directly calculated from a pandas DataFrame object or using summary data.
+
+Other handy features include; splines, Table 1 generator, interaction contrast, interaction contrast ratio, positive
+predictive value, negative predictive value, screening cost analyzer, counternull p-values, convert odds to
+proportions, convert proportions to odds
+
+For guided tutorials with Jupyter Notebooks:
+https://github.com/pzivich/Python-for-Epidemiologists/blob/master/3_Epidemiology_Analysis/a_basics/1_basic_measures.ipynb
+
+## Graphics
+Uses matplotlib in the background to generate some useful plots. Implemented plots include; functional form assessment
+(with statsmodels output), p-value function plots, spaghetti plot, effect measure plot (forest plot), receiver-operator
+curve, dynamic risk plots, and L'Abbe plots
+
+For examples see:
+http://zepid.readthedocs.io/en/latest/Graphics.html
+
+## Causal
+The causal branch includes various estimators for causal inference with observational data. Details on currently
+implemented estimators are below:
+
+### G-Computation Algorithm
+Current implementation includes; time-fixed exposure g-formula, Monte Carlo g-formula, and iterative conditional
+g-formula
+
+### Inverse Probability Weights
+Current implementation includes; IP Treatment W, IP Censoring W, IP Missing W. Diagnostics are also available for IPTW.
+IPMW supports monotone missing data
+
+### Augmented Inverse Probability Weights
+Current implementation includes the augmented-IPTW estimator described by Funk et al 2011 AJE
+
+### Targeted Maximum Likelihood Estimator
+TMLE can be estimated through standard logistic regression model, or through user-input functions. Alternatively, users
+can input machine learning algorithms to estimate probabilities. Supported machine learning algorithms include `sklearn`
+
+### Generalizability / Transportability
+For generalizing results or transporting to a different target population, several estimators are available. These
+include inverse probability of sampling weights, g-transport formula, and doubly robust formulas
+
+Tutorials for the usage of these estimators are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/c_causal_inference
+
+#### G-estimation of Structural Nested Mean Models
+Single time-point g-estimation of structural nested mean models are supported.
+
+## Sensitivity Analyses
+Includes trapezoidal distribution generator, corrected Risk Ratio
+
+Tutorials are available at:
+https://github.com/pzivich/Python-for-Epidemiologists/tree/master/3_Epidemiology_Analysis/d_sensitivity_analyses
+
+
+
+
+%prep
+%autosetup -n zepid-0.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-zepid -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.1-1
+- Package Spec generated