summaryrefslogtreecommitdiff
path: root/python-zoho-analytics-connector.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zoho-analytics-connector.spec')
-rw-r--r--python-zoho-analytics-connector.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-zoho-analytics-connector.spec b/python-zoho-analytics-connector.spec
new file mode 100644
index 0000000..9c542d0
--- /dev/null
+++ b/python-zoho-analytics-connector.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-zoho-analytics-connector
+Version: 1.4.2
+Release: 1
+Summary: Zoho Analytics connector
+License: MPL-2.0
+URL: https://github.com/timrichardson/zoho_analytics_connector
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/09/ac/88943d2b7c0f319189c26c74d6f7b3a0757cf98b3a9f2260cf0a2f3605e8/zoho_analytics_connector-1.4.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-emoji
+
+%description
+Zoho's Python SDK for Zoho Reports is old, however it is very complete.
+This is a version which is Python 3 ready, tested on Python 3.8 and 3.9 and in fairly substantial production use.
+A more convenient wrapper class is in enhanced_report_client. This is based on Zoho's ReportClient but provides some more convenient features.
+I use it mostly for uploading data, and creating and modifying tables.
+This library uses the Analytics V1 API and as of v.1.4 will phase in v2 API endpoints bit by bit
+
+%package -n python3-zoho-analytics-connector
+Summary: Zoho Analytics connector
+Provides: python-zoho-analytics-connector
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-zoho-analytics-connector
+Zoho's Python SDK for Zoho Reports is old, however it is very complete.
+This is a version which is Python 3 ready, tested on Python 3.8 and 3.9 and in fairly substantial production use.
+A more convenient wrapper class is in enhanced_report_client. This is based on Zoho's ReportClient but provides some more convenient features.
+I use it mostly for uploading data, and creating and modifying tables.
+This library uses the Analytics V1 API and as of v.1.4 will phase in v2 API endpoints bit by bit
+
+%package help
+Summary: Development documents and examples for zoho-analytics-connector
+Provides: python3-zoho-analytics-connector-doc
+%description help
+Zoho's Python SDK for Zoho Reports is old, however it is very complete.
+This is a version which is Python 3 ready, tested on Python 3.8 and 3.9 and in fairly substantial production use.
+A more convenient wrapper class is in enhanced_report_client. This is based on Zoho's ReportClient but provides some more convenient features.
+I use it mostly for uploading data, and creating and modifying tables.
+This library uses the Analytics V1 API and as of v.1.4 will phase in v2 API endpoints bit by bit
+
+%prep
+%autosetup -n zoho-analytics-connector-1.4.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-zoho-analytics-connector -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.2-1
+- Package Spec generated