summaryrefslogtreecommitdiff
path: root/python-zulu.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zulu.spec')
-rw-r--r--python-zulu.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-zulu.spec b/python-zulu.spec
new file mode 100644
index 0000000..5e67065
--- /dev/null
+++ b/python-zulu.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-zulu
+Version: 2.0.0
+Release: 1
+Summary: A drop-in replacement for native datetimes that embraces UTC
+License: MIT License
+URL: https://github.com/dgilland/zulu
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a0/07/bb280a5e51f2da35e2c8b2f7f11e75998443d5fafa84a84e896d9f2a274e/zulu-2.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Babel
+Requires: python3-iso8601
+Requires: python3-dateutil
+Requires: python3-pytimeparse
+Requires: python3-black
+Requires: python3-coverage
+Requires: python3-docformatter
+Requires: python3-flake8
+Requires: python3-flake8-black
+Requires: python3-flake8-bugbear
+Requires: python3-flake8-isort
+Requires: python3-invoke
+Requires: python3-isort
+Requires: python3-pylint
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-pytest-flake8
+Requires: python3-pytest-pylint
+Requires: python3-pytz
+Requires: python3-Sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-tox
+Requires: python3-twine
+Requires: python3-wheel
+
+%description
+- Project: https://github.com/dgilland/zulu
+- Documentation: https://zulu.readthedocs.io
+- PyPI: https://pypi.python.org/pypi/zulu/
+- Github Actions: https://github.com/dgilland/zulu/actions
+
+%package -n python3-zulu
+Summary: A drop-in replacement for native datetimes that embraces UTC
+Provides: python-zulu
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-zulu
+- Project: https://github.com/dgilland/zulu
+- Documentation: https://zulu.readthedocs.io
+- PyPI: https://pypi.python.org/pypi/zulu/
+- Github Actions: https://github.com/dgilland/zulu/actions
+
+%package help
+Summary: Development documents and examples for zulu
+Provides: python3-zulu-doc
+%description help
+- Project: https://github.com/dgilland/zulu
+- Documentation: https://zulu.readthedocs.io
+- PyPI: https://pypi.python.org/pypi/zulu/
+- Github Actions: https://github.com/dgilland/zulu/actions
+
+%prep
+%autosetup -n zulu-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-zulu -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated