summaryrefslogtreecommitdiff
path: root/python-bibtexparser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bibtexparser.spec')
-rw-r--r--python-bibtexparser.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-bibtexparser.spec b/python-bibtexparser.spec
new file mode 100644
index 0000000..de75e17
--- /dev/null
+++ b/python-bibtexparser.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-bibtexparser
+Version: 1.4.0
+Release: 1
+Summary: Bibtex parser for python 3
+License: LGPLv3 or BSD
+URL: https://github.com/sciunto-org/python-bibtexparser
+Source0: https://files.pythonhosted.org/packages/82/60/e4315ce9801daa4c95d4ae66cc684a1780cc041ba3c4eab67265ab08a038/bibtexparser-1.4.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Python library to parse `bibtex <https://en.wikipedia.org/wiki/BibTeX>`_ files.
+Bibtexparser relies on `pyparsing <https://pypi.python.org/pypi/pyparsing>`_ and is compatible with Python 3.3 or newer.
+
+%package -n python3-bibtexparser
+Summary: Bibtex parser for python 3
+Provides: python-bibtexparser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-bibtexparser
+Python library to parse `bibtex <https://en.wikipedia.org/wiki/BibTeX>`_ files.
+Bibtexparser relies on `pyparsing <https://pypi.python.org/pypi/pyparsing>`_ and is compatible with Python 3.3 or newer.
+
+%package help
+Summary: Development documents and examples for bibtexparser
+Provides: python3-bibtexparser-doc
+%description help
+Python library to parse `bibtex <https://en.wikipedia.org/wiki/BibTeX>`_ files.
+Bibtexparser relies on `pyparsing <https://pypi.python.org/pypi/pyparsing>`_ and is compatible with Python 3.3 or newer.
+
+%prep
+%autosetup -n bibtexparser-1.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-bibtexparser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.0-1
+- Package Spec generated