summaryrefslogtreecommitdiff
path: root/python-booleanoperations.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-booleanoperations.spec')
-rw-r--r--python-booleanoperations.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-booleanoperations.spec b/python-booleanoperations.spec
new file mode 100644
index 0000000..fc7d20e
--- /dev/null
+++ b/python-booleanoperations.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-booleanOperations
+Version: 0.9.0
+Release: 1
+Summary: Boolean operations on paths.
+License: MIT
+URL: https://github.com/typemytype/booleanOperations
+Source0: https://files.pythonhosted.org/packages/57/d9/9eae7bc4ba3a38ab7426522fb08e12df54aec27595d7bcd1bc0670aec873/booleanOperations-0.9.0.zip
+BuildArch: noarch
+
+Requires: python3-pyclipper
+Requires: python3-fonttools
+
+%description
+Boolean operations on paths which uses a super fast `polygon clipper
+library by Angus Johnson <http://www.angusj.com/delphi/clipper.php>`__.
+You can download the latest version from PyPI:
+https://pypi.org/project/booleanOperations.
+
+%package -n python3-booleanOperations
+Summary: Boolean operations on paths.
+Provides: python-booleanOperations
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-booleanOperations
+Boolean operations on paths which uses a super fast `polygon clipper
+library by Angus Johnson <http://www.angusj.com/delphi/clipper.php>`__.
+You can download the latest version from PyPI:
+https://pypi.org/project/booleanOperations.
+
+%package help
+Summary: Development documents and examples for booleanOperations
+Provides: python3-booleanOperations-doc
+%description help
+Boolean operations on paths which uses a super fast `polygon clipper
+library by Angus Johnson <http://www.angusj.com/delphi/clipper.php>`__.
+You can download the latest version from PyPI:
+https://pypi.org/project/booleanOperations.
+
+%prep
+%autosetup -n booleanOperations-0.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-booleanOperations -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
+- Package Spec generated