summaryrefslogtreecommitdiff
path: root/python-cloudscraper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cloudscraper.spec')
-rw-r--r--python-cloudscraper.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-cloudscraper.spec b/python-cloudscraper.spec
new file mode 100644
index 0000000..a30d74c
--- /dev/null
+++ b/python-cloudscraper.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cloudscraper
+Version: 1.2.68
+Release: 1
+Summary: A Python module to bypass Cloudflare's anti-bot page.
+License: MIT License
+URL: https://github.com/venomous/cloudscraper
+Source0: https://files.pythonhosted.org/packages/09/ba/71b989352ceee1fbbc1bbfc658ac677a506b4bbfdc0f527b6f81435cf3fa/cloudscraper-1.2.68.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyparsing
+Requires: python3-requests
+Requires: python3-requests-toolbelt
+
+%description
+### Brotli
+#### Description
+[Brotli](https://en.wikipedia.org/wiki/Brotli) decompression support has been added, and it is enabled by default.
+#### Parameters
+|Parameter|Value|Default|
+|-------------|:-------------:|:-----:|
+|allow_brotli|(boolean)|True|
+#### Example
+```python
+scraper = cloudscraper.create_scraper(allow_brotli=False)
+
+%package -n python3-cloudscraper
+Summary: A Python module to bypass Cloudflare's anti-bot page.
+Provides: python-cloudscraper
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-cloudscraper
+### Brotli
+#### Description
+[Brotli](https://en.wikipedia.org/wiki/Brotli) decompression support has been added, and it is enabled by default.
+#### Parameters
+|Parameter|Value|Default|
+|-------------|:-------------:|:-----:|
+|allow_brotli|(boolean)|True|
+#### Example
+```python
+scraper = cloudscraper.create_scraper(allow_brotli=False)
+
+%package help
+Summary: Development documents and examples for cloudscraper
+Provides: python3-cloudscraper-doc
+%description help
+### Brotli
+#### Description
+[Brotli](https://en.wikipedia.org/wiki/Brotli) decompression support has been added, and it is enabled by default.
+#### Parameters
+|Parameter|Value|Default|
+|-------------|:-------------:|:-----:|
+|allow_brotli|(boolean)|True|
+#### Example
+```python
+scraper = cloudscraper.create_scraper(allow_brotli=False)
+
+%prep
+%autosetup -n cloudscraper-1.2.68
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cloudscraper -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.68-1
+- Package Spec generated