summaryrefslogtreecommitdiff
path: root/python-cmigemo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cmigemo.spec')
-rw-r--r--python-cmigemo.spec71
1 files changed, 71 insertions, 0 deletions
diff --git a/python-cmigemo.spec b/python-cmigemo.spec
new file mode 100644
index 0000000..b74a588
--- /dev/null
+++ b/python-cmigemo.spec
@@ -0,0 +1,71 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cmigemo
+Version: 0.1.6
+Release: 1
+Summary: A pure python binding for C/Migemo
+License: MIT
+URL: https://github.com/mooz/python-cmigemo
+Source0: https://files.pythonhosted.org/packages/2f/e4/374df50b655e36139334046f898469bf5e2d7600e1e638f29baf05b14b72/cmigemo-0.1.6.tar.gz
+BuildArch: noarch
+
+
+%description
+A C/Migemo binding for python written in pure python using ctypes.
+
+%package -n python3-cmigemo
+Summary: A pure python binding for C/Migemo
+Provides: python-cmigemo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-cmigemo
+A C/Migemo binding for python written in pure python using ctypes.
+
+%package help
+Summary: Development documents and examples for cmigemo
+Provides: python3-cmigemo-doc
+%description help
+A C/Migemo binding for python written in pure python using ctypes.
+
+%prep
+%autosetup -n cmigemo-0.1.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cmigemo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.6-1
+- Package Spec generated