summaryrefslogtreecommitdiff
path: root/python-colcon-ros-bazel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-colcon-ros-bazel.spec')
-rw-r--r--python-colcon-ros-bazel.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-colcon-ros-bazel.spec b/python-colcon-ros-bazel.spec
new file mode 100644
index 0000000..396485c
--- /dev/null
+++ b/python-colcon-ros-bazel.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-colcon-ros-bazel
+Version: 0.0.1
+Release: 1
+Summary: Extension for colcon to support ROS2 Bazel packages.
+License: Apache License, Version 2.0
+URL: https://colcon.readthedocs.io
+Source0: https://files.pythonhosted.org/packages/74/ec/0ecca5811aefa1ed85afe76e57345a898de7bb51b9b207fbe879a77cba4b/colcon-ros-bazel-0.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-colcon-core
+Requires: python3-colcon-bazel
+Requires: python3-colcon-library-path
+Requires: python3-colcon-ros
+
+%description
+[![Travis CI](https://travis-ci.org/colcon/colcon-ros-bazel.svg?branch=master)](https://travis-ci.org/colcon/colcon-ros-bazel)
+[![AppVeyor](https://ci.appveyor.com/api/projects/status/github/colcon/colcon-ros-bazel?svg=true&branch=master)](https://ci.appveyor.com/project/Theosakamg/colcon-ros-bazel)
+[![codecov](https://codecov.io/gh/colcon/colcon-ros-bazel/branch/master/graph/badge.svg)](https://codecov.io/gh/colcon/colcon-ros-bazel)
+[![PyPI version](https://img.shields.io/pypi/v/colcon_ros_bazel.svg)](https://pypi.python.org/pypi/colcon_ros_bazel/)
+An extension for [colcon-core](https://github.com/colcon/colcon-core) to support ROS2 Bazel projects.
+
+%package -n python3-colcon-ros-bazel
+Summary: Extension for colcon to support ROS2 Bazel packages.
+Provides: python-colcon-ros-bazel
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-colcon-ros-bazel
+[![Travis CI](https://travis-ci.org/colcon/colcon-ros-bazel.svg?branch=master)](https://travis-ci.org/colcon/colcon-ros-bazel)
+[![AppVeyor](https://ci.appveyor.com/api/projects/status/github/colcon/colcon-ros-bazel?svg=true&branch=master)](https://ci.appveyor.com/project/Theosakamg/colcon-ros-bazel)
+[![codecov](https://codecov.io/gh/colcon/colcon-ros-bazel/branch/master/graph/badge.svg)](https://codecov.io/gh/colcon/colcon-ros-bazel)
+[![PyPI version](https://img.shields.io/pypi/v/colcon_ros_bazel.svg)](https://pypi.python.org/pypi/colcon_ros_bazel/)
+An extension for [colcon-core](https://github.com/colcon/colcon-core) to support ROS2 Bazel projects.
+
+%package help
+Summary: Development documents and examples for colcon-ros-bazel
+Provides: python3-colcon-ros-bazel-doc
+%description help
+[![Travis CI](https://travis-ci.org/colcon/colcon-ros-bazel.svg?branch=master)](https://travis-ci.org/colcon/colcon-ros-bazel)
+[![AppVeyor](https://ci.appveyor.com/api/projects/status/github/colcon/colcon-ros-bazel?svg=true&branch=master)](https://ci.appveyor.com/project/Theosakamg/colcon-ros-bazel)
+[![codecov](https://codecov.io/gh/colcon/colcon-ros-bazel/branch/master/graph/badge.svg)](https://codecov.io/gh/colcon/colcon-ros-bazel)
+[![PyPI version](https://img.shields.io/pypi/v/colcon_ros_bazel.svg)](https://pypi.python.org/pypi/colcon_ros_bazel/)
+An extension for [colcon-core](https://github.com/colcon/colcon-core) to support ROS2 Bazel projects.
+
+%prep
+%autosetup -n colcon-ros-bazel-0.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-colcon-ros-bazel -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.1-1
+- Package Spec generated