summaryrefslogtreecommitdiff
path: root/python-copr-messaging.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-copr-messaging.spec')
-rw-r--r--python-copr-messaging.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-copr-messaging.spec b/python-copr-messaging.spec
new file mode 100644
index 0000000..11e0a9d
--- /dev/null
+++ b/python-copr-messaging.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-copr-messaging
+Version: 0.8
+Release: 1
+Summary: A schema and tooling for Copr fedora-messaging
+License: GPLv2+
+URL: https://github.com/fedora-copr/copr
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b7/2b/d360b288dc2f6b303a42c1a90c58eaf7f8a7d7c523723cbe092e91ab5d55/copr-messaging-0.8.tar.gz
+BuildArch: noarch
+
+
+%description
+Schemas for messages sent by Copr project, as described on
+[fedora-messaging documentation page].
+This package also provides several convenience methods for working with copr
+messages, see docs.
+[fedora-messaging documentation page]: https://fedora-messaging.readthedocs.io/en/latest/messages.html#schema
+
+%package -n python3-copr-messaging
+Summary: A schema and tooling for Copr fedora-messaging
+Provides: python-copr-messaging
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-copr-messaging
+Schemas for messages sent by Copr project, as described on
+[fedora-messaging documentation page].
+This package also provides several convenience methods for working with copr
+messages, see docs.
+[fedora-messaging documentation page]: https://fedora-messaging.readthedocs.io/en/latest/messages.html#schema
+
+%package help
+Summary: Development documents and examples for copr-messaging
+Provides: python3-copr-messaging-doc
+%description help
+Schemas for messages sent by Copr project, as described on
+[fedora-messaging documentation page].
+This package also provides several convenience methods for working with copr
+messages, see docs.
+[fedora-messaging documentation page]: https://fedora-messaging.readthedocs.io/en/latest/messages.html#schema
+
+%prep
+%autosetup -n copr-messaging-0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-copr-messaging -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
+- Package Spec generated