summaryrefslogtreecommitdiff
path: root/python-distroinfo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-distroinfo.spec')
-rw-r--r--python-distroinfo.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-distroinfo.spec b/python-distroinfo.spec
new file mode 100644
index 0000000..a5c40f9
--- /dev/null
+++ b/python-distroinfo.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-distroinfo
+Version: 0.5.1
+Release: 1
+Summary: python module for parsing, validating and querying distribution/packaging metadata stored in human readable and reviewable text/YAML files
+License: Apache Software License
+URL: https://github.com/softwarefactory-project/distroinfo
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/05/44241fff6593efe036710f630eef31f3eaf97845af16172672d775be07b3/distroinfo-0.5.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pbr
+Requires: python3-PyYAML
+Requires: python3-requests
+Requires: python3-six
+
+%description
+``distroinfo`` is a python module for parsing, validating and querying
+distribution/packaging metadata stored in human readable and reviewable
+text/YAML files.
+This is a proper generic (re)implementation of
+`rdoinfo <https://github.com/redhat-openstack/rdoinfo>`__ parser which
+proved well suited for the task of interfacing with distribution
+metadata in a human friendly way. If you consider code reviews human
+friendly, that is.
+``distroinfo`` is a part of `Software Factory
+project <https://softwarefactory-project.io/docs/>`__
+
+%package -n python3-distroinfo
+Summary: python module for parsing, validating and querying distribution/packaging metadata stored in human readable and reviewable text/YAML files
+Provides: python-distroinfo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-distroinfo
+``distroinfo`` is a python module for parsing, validating and querying
+distribution/packaging metadata stored in human readable and reviewable
+text/YAML files.
+This is a proper generic (re)implementation of
+`rdoinfo <https://github.com/redhat-openstack/rdoinfo>`__ parser which
+proved well suited for the task of interfacing with distribution
+metadata in a human friendly way. If you consider code reviews human
+friendly, that is.
+``distroinfo`` is a part of `Software Factory
+project <https://softwarefactory-project.io/docs/>`__
+
+%package help
+Summary: Development documents and examples for distroinfo
+Provides: python3-distroinfo-doc
+%description help
+``distroinfo`` is a python module for parsing, validating and querying
+distribution/packaging metadata stored in human readable and reviewable
+text/YAML files.
+This is a proper generic (re)implementation of
+`rdoinfo <https://github.com/redhat-openstack/rdoinfo>`__ parser which
+proved well suited for the task of interfacing with distribution
+metadata in a human friendly way. If you consider code reviews human
+friendly, that is.
+``distroinfo`` is a part of `Software Factory
+project <https://softwarefactory-project.io/docs/>`__
+
+%prep
+%autosetup -n distroinfo-0.5.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-distroinfo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
+- Package Spec generated