summaryrefslogtreecommitdiff
path: root/python-drat.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-drat.spec')
-rw-r--r--python-drat.spec170
1 files changed, 170 insertions, 0 deletions
diff --git a/python-drat.spec b/python-drat.spec
new file mode 100644
index 0000000..b620828
--- /dev/null
+++ b/python-drat.spec
@@ -0,0 +1,170 @@
+%global _empty_manifest_terminate_build 0
+Name: python-drat
+Version: 1.0.3
+Release: 1
+Summary: A reading text analysis tool
+License: GPLv3
+URL: https://github.com/riverrun/drat
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/16/48/c8f71f56f0714c5731c3325ff35721c8cba18b0424eea320f6807abf88fe/drat-1.0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+Text (readability) analysis tool written in Python (2.7 and 3).
+Features
+~~~~~~~~
+Drat is a tool that analyzes reading texts and produces a brief report
+which provides the following information:
+- the Dale-Chall readability score.
+- the Coleman-Liau Readability Index.
+- the number of uncommon words (based on the General Service List).
+- a list of all of these uncommon words (if you choose the verbose option).
+Drat supports **docx**, **odt**, **ods**, **odp** files as well as text
+files and urls.
+You can also analyze multiple texts / links by creating a text file
+with the filenames / links written in it.
+A simple example of how drat can be used in a web application is provided in the
+webapp directory.
+Use
+~~~
+Please read the `wiki <https://github.com/riverrun/drat/wiki>`_ for information about how to use drat.
+Dependencies
+~~~~~~~~~~~~
+Python (2.7 or 3), click and requests.
+Name
+~~~~
+Drat is a recursive acronym which either stands for Drat is a Readability
+Analysis Tool or Drat is a Rabid Assessor of Texts.
+Author
+~~~~~~
+This program has been developed by David Whitlock.
+License
+~~~~~~~
+Drat is free software: you can redistribute it and/or modify it under
+the terms of the GNU General Public License as published by the Free
+Software Foundation, either version 3 of the License, or (at your
+option) any later version.
+
+%package -n python3-drat
+Summary: A reading text analysis tool
+Provides: python-drat
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-drat
+Text (readability) analysis tool written in Python (2.7 and 3).
+Features
+~~~~~~~~
+Drat is a tool that analyzes reading texts and produces a brief report
+which provides the following information:
+- the Dale-Chall readability score.
+- the Coleman-Liau Readability Index.
+- the number of uncommon words (based on the General Service List).
+- a list of all of these uncommon words (if you choose the verbose option).
+Drat supports **docx**, **odt**, **ods**, **odp** files as well as text
+files and urls.
+You can also analyze multiple texts / links by creating a text file
+with the filenames / links written in it.
+A simple example of how drat can be used in a web application is provided in the
+webapp directory.
+Use
+~~~
+Please read the `wiki <https://github.com/riverrun/drat/wiki>`_ for information about how to use drat.
+Dependencies
+~~~~~~~~~~~~
+Python (2.7 or 3), click and requests.
+Name
+~~~~
+Drat is a recursive acronym which either stands for Drat is a Readability
+Analysis Tool or Drat is a Rabid Assessor of Texts.
+Author
+~~~~~~
+This program has been developed by David Whitlock.
+License
+~~~~~~~
+Drat is free software: you can redistribute it and/or modify it under
+the terms of the GNU General Public License as published by the Free
+Software Foundation, either version 3 of the License, or (at your
+option) any later version.
+
+%package help
+Summary: Development documents and examples for drat
+Provides: python3-drat-doc
+%description help
+Text (readability) analysis tool written in Python (2.7 and 3).
+Features
+~~~~~~~~
+Drat is a tool that analyzes reading texts and produces a brief report
+which provides the following information:
+- the Dale-Chall readability score.
+- the Coleman-Liau Readability Index.
+- the number of uncommon words (based on the General Service List).
+- a list of all of these uncommon words (if you choose the verbose option).
+Drat supports **docx**, **odt**, **ods**, **odp** files as well as text
+files and urls.
+You can also analyze multiple texts / links by creating a text file
+with the filenames / links written in it.
+A simple example of how drat can be used in a web application is provided in the
+webapp directory.
+Use
+~~~
+Please read the `wiki <https://github.com/riverrun/drat/wiki>`_ for information about how to use drat.
+Dependencies
+~~~~~~~~~~~~
+Python (2.7 or 3), click and requests.
+Name
+~~~~
+Drat is a recursive acronym which either stands for Drat is a Readability
+Analysis Tool or Drat is a Rabid Assessor of Texts.
+Author
+~~~~~~
+This program has been developed by David Whitlock.
+License
+~~~~~~~
+Drat is free software: you can redistribute it and/or modify it under
+the terms of the GNU General Public License as published by the Free
+Software Foundation, either version 3 of the License, or (at your
+option) any later version.
+
+%prep
+%autosetup -n drat-1.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-drat -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
+- Package Spec generated