summaryrefslogtreecommitdiff
path: root/python-dukpy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dukpy.spec')
-rw-r--r--python-dukpy.spec98
1 files changed, 98 insertions, 0 deletions
diff --git a/python-dukpy.spec b/python-dukpy.spec
new file mode 100644
index 0000000..bdd4384
--- /dev/null
+++ b/python-dukpy.spec
@@ -0,0 +1,98 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dukpy
+Version: 0.3.0
+Release: 1
+Summary: Simple JavaScript interpreter for Python
+License: MIT
+URL: https://github.com/amol-/dukpy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/73/8b/d53ee945bd9f915a14dae1f9aade23d010dec309a2a2b426803bff937f00/dukpy-0.3.0.tar.gz
+
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-mock
+Requires: python3-webassets
+
+%description
+DukPy is a simple javascript interpreter for Python built on top of
+duktape engine **without any external dependency**.
+It comes with a bunch of common transpilers built-in for convenience:
+ - *CoffeeScript*
+ - *BabelJS*
+ - *TypeScript*
+ - *JSX*
+ - *LESS*
+
+%package -n python3-dukpy
+Summary: Simple JavaScript interpreter for Python
+Provides: python-dukpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-dukpy
+DukPy is a simple javascript interpreter for Python built on top of
+duktape engine **without any external dependency**.
+It comes with a bunch of common transpilers built-in for convenience:
+ - *CoffeeScript*
+ - *BabelJS*
+ - *TypeScript*
+ - *JSX*
+ - *LESS*
+
+%package help
+Summary: Development documents and examples for dukpy
+Provides: python3-dukpy-doc
+%description help
+DukPy is a simple javascript interpreter for Python built on top of
+duktape engine **without any external dependency**.
+It comes with a bunch of common transpilers built-in for convenience:
+ - *CoffeeScript*
+ - *BabelJS*
+ - *TypeScript*
+ - *JSX*
+ - *LESS*
+
+%prep
+%autosetup -n dukpy-0.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dukpy -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
+- Package Spec generated