summaryrefslogtreecommitdiff
path: root/python-flask-socketio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-socketio.spec')
-rw-r--r--python-flask-socketio.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-flask-socketio.spec b/python-flask-socketio.spec
new file mode 100644
index 0000000..1d6c0a5
--- /dev/null
+++ b/python-flask-socketio.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-SocketIO
+Version: 5.3.2
+Release: 1
+Summary: Socket.IO integration for Flask applications
+License: MIT License
+URL: https://github.com/miguelgrinberg/flask-socketio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/b3/70d1f126998189db30f4fab0102d8c9ae05de071f0297123ee255db08e51/Flask-SocketIO-5.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-Flask
+Requires: python3-socketio
+
+%description
+[![Build status](https://github.com/miguelgrinberg/flask-socketio/workflows/build/badge.svg)](https://github.com/miguelgrinberg/Flask-SocketIO/actions) [![codecov](https://codecov.io/gh/miguelgrinberg/flask-socketio/branch/main/graph/badge.svg)](https://codecov.io/gh/miguelgrinberg/flask-socketio)
+Socket.IO integration for Flask applications.
+
+%package -n python3-Flask-SocketIO
+Summary: Socket.IO integration for Flask applications
+Provides: python-Flask-SocketIO
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-Flask-SocketIO
+[![Build status](https://github.com/miguelgrinberg/flask-socketio/workflows/build/badge.svg)](https://github.com/miguelgrinberg/Flask-SocketIO/actions) [![codecov](https://codecov.io/gh/miguelgrinberg/flask-socketio/branch/main/graph/badge.svg)](https://codecov.io/gh/miguelgrinberg/flask-socketio)
+Socket.IO integration for Flask applications.
+
+%package help
+Summary: Development documents and examples for Flask-SocketIO
+Provides: python3-Flask-SocketIO-doc
+%description help
+[![Build status](https://github.com/miguelgrinberg/flask-socketio/workflows/build/badge.svg)](https://github.com/miguelgrinberg/Flask-SocketIO/actions) [![codecov](https://codecov.io/gh/miguelgrinberg/flask-socketio/branch/main/graph/badge.svg)](https://codecov.io/gh/miguelgrinberg/flask-socketio)
+Socket.IO integration for Flask applications.
+
+%prep
+%autosetup -n Flask-SocketIO-5.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-SocketIO -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 5.3.2-1
+- Package Spec generated