summaryrefslogtreecommitdiff
path: root/python-friendlyloris.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-friendlyloris.spec')
-rw-r--r--python-friendlyloris.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-friendlyloris.spec b/python-friendlyloris.spec
new file mode 100644
index 0000000..bb371c1
--- /dev/null
+++ b/python-friendlyloris.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-friendlyloris
+Version: 1.0.1
+Release: 1
+Summary: A Slow Loris package for Python
+License: MIT License
+URL: https://github.com/jackdcasey/friendlyloris
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b7/a3/ed4a9b7dcae3bbd44e562c85c421888f24daa27452dfe0b63c492fc050c2/friendlyloris-1.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+#TODO
+
+
+
+
+%package -n python3-friendlyloris
+Summary: A Slow Loris package for Python
+Provides: python-friendlyloris
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-friendlyloris
+#TODO
+
+
+
+
+%package help
+Summary: Development documents and examples for friendlyloris
+Provides: python3-friendlyloris-doc
+%description help
+#TODO
+
+
+
+
+%prep
+%autosetup -n friendlyloris-1.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-friendlyloris -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
+- Package Spec generated