summaryrefslogtreecommitdiff
path: root/python-genty.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-genty.spec')
-rw-r--r--python-genty.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-genty.spec b/python-genty.spec
new file mode 100644
index 0000000..d326dd9
--- /dev/null
+++ b/python-genty.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-genty
+Version: 1.3.2
+Release: 1
+Summary: Allows you to run a test with multiple data sets
+License: Apache Software License, Version 2.0, http://www.apache.org/licenses/LICENSE-2.0
+URL: https://github.com/box/genty
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/bc/eee096fe9ecf1041944f1327cf6a2030fb2c59acd66580b692eb8b540233/genty-1.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-ordereddict
+
+%description
+
+
+%package -n python3-genty
+Summary: Allows you to run a test with multiple data sets
+Provides: python-genty
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-genty
+
+
+%package help
+Summary: Development documents and examples for genty
+Provides: python3-genty-doc
+%description help
+
+
+%prep
+%autosetup -n genty-1.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-genty -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.2-1
+- Package Spec generated