summaryrefslogtreecommitdiff
path: root/python-geoip2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-geoip2.spec')
-rw-r--r--python-geoip2.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-geoip2.spec b/python-geoip2.spec
new file mode 100644
index 0000000..211e1c1
--- /dev/null
+++ b/python-geoip2.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-geoip2
+Version: 4.6.0
+Release: 1
+Summary: MaxMind GeoIP2 API
+License: Apache License, Version 2.0
+URL: http://www.maxmind.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/51/3fb1651db4bcb44d69a19b5e82e037f4de1b077974c7549adf8f3d42218b/geoip2-4.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-maxminddb
+Requires: python3-requests
+Requires: python3-urllib3
+
+%description
+
+
+%package -n python3-geoip2
+Summary: MaxMind GeoIP2 API
+Provides: python-geoip2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-geoip2
+
+
+%package help
+Summary: Development documents and examples for geoip2
+Provides: python3-geoip2-doc
+%description help
+
+
+%prep
+%autosetup -n geoip2-4.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-geoip2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 4.6.0-1
+- Package Spec generated